clamd ignores Selfcheck setting?

Discussion in 'Server Operation' started by Scott Horton, Jul 22, 2016.

  1. Scott Horton

    Scott Horton New Member

    I finally got Postfix, Amavisd, Spamassassin and Clamd working together on Centos7. I wanted to reduce the timing that clamd does its Selfcheck. The default is 600. My configuration file is located at
    /etc/clamd.d/scan.conf
    and, I also have /etc/clamd.conf linked to it.
    I've changed the parameter in the conf file to
    # Perform a database check.
    # Default: 600 (10 min)
    #SelfCheck 600
    SelfCheck 3600
    Restarted everything via systemctl to be sure (postfix, AMavisd, Clamd, spamassassin).

    But in my maillog, I still get the steady checks every 600 seconds:

    Jul 21 21:15:24 tn4 clamd[3073]: SelfCheck: Database status OK.
    Jul 21 21:25:24 tn4 clamd[3073]: SelfCheck: Database status OK.
    Jul 21 21:35:24 tn4 clamd[3073]: SelfCheck: Database status OK.
    Jul 21 21:45:24 tn4 clamd[3073]: SelfCheck: Database status OK.
    Jul 21 21:55:24 tn4 clamd[3073]: SelfCheck: Database status OK.

    I checked which service was actually running adn that it is th eonly clamd related process running:
    [email protected] loaded active running

    I checked what I think is that configuration file for systemctl
    /usr/lib/systemd/system/clamd@.service
    and it appers to be using the conf file I think it is:
    ExecStart = /usr/sbin/clamd -c /etc/clamd.d/%i.conf --foreground=yes

    Or is it? Not sure what the %i resolves to. I think I saw that was amavisd somewhere.

    So, I tried editing that service starting file and manually pointing it to start with "-c /etc/clamd.conf" That appears to made some difference, as it moved the logging from maillog to /var/log/messages.

    But now it says:
    Jul 21 22:23:08 tn4 clamd: ERROR: Please define server type (local and/or TCP).
    Jul 21 22:23:08 tn4 systemd: [email protected]: main process exited, code=exited, status=1/FAILURE
    Jul 21 22:23:08 tn4 systemd: Unit [email protected] entered failed state.
    Jul 21 22:23:08 tn4 systemd: [email protected] failed.

    So I looked that up. My conf file does have the LocalSocket line uncommented and a file defined:
    # Default: disabled (must be specified by a user)
    LocalSocket /var/run/clamd.amavisd/clamd.sock

    I surmise fro this that wile I had clamd running without error, it is apparently starting up with defaults and not using my config file.

    Help?
     

Share This Page