Clamd.amavisd start error

Discussion in 'Installation/Configuration' started by robertlouwen, Mar 12, 2010.

  1. robertlouwen

    robertlouwen New Member

    Hello Falko,

    Sorry it's me again about this issue. Is the last line in the code box something to worry about ?
    To me it looks like clamd.amavisd is not running
    Code:
    Last login: Tue Apr 20 22:55:41 2010 from 192.168.0.1
    -bash-4.0# ps aux | grep clamd.amavisd
    amavis    1626  0.0  9.1 118180 93620 ?        Ssl  22:57   0:00 clamd.amavisd -c /etc/clamd.d/amavisd.conf --pid /var/run/clamd.amavisd/clamd.pid
    root      5870  0.0  0.0   4220   748 pts/0    S+   23:02   0:00 grep clamd.amavisd
    You have new mail in /var/spool/mail/root
    -bash-4.0# kill -9 1626
    -bash-4.0# rm -f /var/spool/amavisd/clamd.sock
    -bash-4.0# /etc/init.d/clamd.amavisd start
    Starting clamd.amavisd: LibClamAV Warning: ***********************************************************
    LibClamAV Warning: ***  This version of the ClamAV engine is outdated.     ***
    LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
    LibClamAV Warning: ***********************************************************
                                                               [  OK  ]
    -bash-4.0# /etc/init.d/clamd.amavisd status
    clamd.amavisd dead but subsys locked
     
  2. falko

    falko Super Moderator

    Please try to restart Clamd.
     
  3. robertlouwen

    robertlouwen New Member

    Now I really feel stupid,

    I have /etc/init.d/amavisd and /etc/init.d/clamd.amavisd but I don't have /etc/init.d/clamd

    Have a good weekend
     
  4. falko

    falko Super Moderator

    Try
    Code:
    /etc/init.d/clamd.amavisd restart
     
  5. robertlouwen

    robertlouwen New Member

    Hello Falko,

    /etc/init.d/clamd.amavisd restart:
    Code:
    Stopping clamd.amavisd:                                    [FAILED]
    Starting clamd.amavisd: LibClamAV Warning: ***********************************************************
    LibClamAV Warning: ***  This version of the ClamAV engine is outdated.     ***
    LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
    LibClamAV Warning: ***********************************************************
    ERROR: LOCAL: Socket file /var/spool/amavisd/clamd.sock is in use by another process.
                                                               [FAILED]
    You have new mail in /var/spool/mail/root
    -bash-4.0#
    Code:
    -bash-4.0# ps aux | grep clamd.amavisd
    amavis   18234  0.0  9.2 129712 93932 ?        Ssl  Apr22   0:48 clamd.amavisd -c /etc/clamd.d/amavisd.conf --pid /var/run/clamd.amavisd/clamd.pid
    root     29883  0.0  0.0   4220   756 pts/0    SN+  00:10   0:00 grep clamd.amavisd
    -bash-4.0# kill -9 18234
    -bash-4.0# rm -f /var/spool/amavisd/clamd.sock
    -bash-4.0# /etc/init.d/clamd.amavisd start
    Starting clamd.amavisd: LibClamAV Warning: ***********************************************************
    LibClamAV Warning: ***  This version of the ClamAV engine is outdated.     ***
    LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
    LibClamAV Warning: ***********************************************************
                                                               [  OK  ]
    -bash-4.0#
     
  6. robertlouwen

    robertlouwen New Member

    After upgrading to Fedora 13 this issue no longer occurs.
     
  7. pturkey

    pturkey New Member

    Better fix

    Fedora 13 and 14 I have found that have the same problem.
    The clamd.pid is the problem not the clamd.sock.

    You can repair this problem two ways.
    1:
    This seems to me to be the best way.
    by editing the /etc/clamd.d/amavisd.conf
    and change the line "PidFile /var/run/amavisd/clamd.pid" to "PidFile /var/run/clamd.amavisd/clamd.pid"
    and create the new folder.
    mkdir /var/run/clamd.amavisd/
    chown amavis.amavis /var/run/clamd.amavisd/

    2:
    I think that this fix will be broken again on the next update.
    edit the /usr/share/clamav/clamd-wrapper
    and change CLAMD_PIDFILE=/var/run/clamd.${CLAMD_SERVICE}/clamd.pid to CLAMD_PIDFILE=/var/run/${CLAMD_SERVICE}/clamd.pid
     

Share This Page