Clamav on Fedora Core 10.

Discussion in 'HOWTO-Related Questions' started by multilan, Apr 16, 2010.

  1. multilan

    multilan New Member

    Hello I just wrote a long winded post and my cookie expired. So now I'll just try to make it quick. I upgraded ISPConfig to 3.0.2.1 and now I cannot receive mail. I am getting the following error when I try to start clamav. Here is what I tried so far:

    -Removing Dovecot and reapplying the update manually.
    -Updating the clamav rpms but there does not seem to be any newer ones for FC10
    -Tried rebuilding the daily.cvd and main.cvd using freshclam. Here is a list or what is installed:

    clamav-data-0.94.2-1.fc10.i386
    clamav-update-0.94.2-1.fc10.i386
    clamav-server-sysv-0.94.2-1.fc10.i386
    clamav-filesystem-0.94.2-1.fc10.i386
    clamav-0.94.2-1.fc10.i386
    clamav-server-0.94.2-1.fc10.i386
    clamav-lib-0.94.2-1.fc10.i386


    Starting clamd.amavisd: LibClamAV Warning: ***********************************************************
    LibClamAV Warning: *** This version of the ClamAV engine is outdated. ***
    LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
    LibClamAV Warning: ***********************************************************
    LibClamAV Error: cli_hex2str(): Malformed hexstring: This ClamAV version has reached End of Life! Please upgrade to version 0.95 or later. For more information see www.clamav.net/eol-clamav-094 and www.clamav.net/download (length: 169)
    LibClamAV Error: Problem parsing database at line 742
    LibClamAV Error: Can't load /tmp/clamav-bd3a668d5b1eac0e7d2c58d9e6e50b8c/daily.ndb: Malformed database
    LibClamAV Error: Can't load /var/lib/clamav/daily.cvd: Malformed database
    ERROR: Malformed database
    [FAILED]


    Any suggestions would be helpfull

    Cheers
     
  2. binaryrogue

    binaryrogue New Member

    Clamav .94 is at end of life. I'm also having the same issue on Fedora 10 and have not found a solution.
     
  3. calivent

    calivent New Member

    Alguien que lo haya hecho, end life Clamav .94

    there no solution to this problem? ... and also tried to create the rpm, I've failed .. I hope that someone has done ... it and work with this community ... and all we have the same problem we can fix it ..

    using FC10 with ispconfig 3.0.2.1
    clamav]# /etc/init.d/clamd.amavisd start
    Iniciando clamd.amavisd: LibClamAV Warning: ***********************************************************
    LibClamAV Warning: *** This version of the ClamAV engine is outdated. ***
    LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
    LibClamAV Warning: ***********************************************************
    LibClamAV Error: cli_hex2str(): Malformed hexstring: This ClamAV version has reached End of Life! Please upgrade to version 0.95 or later. For more information see www.clamav.net/eol-clamav-094 and www.clamav.net/download (length: 169)
    LibClamAV Error: Problem parsing database at line 741
    LibClamAV Error: Can't load daily.ndb: Malformed database
    LibClamAV Error: cli_tgzload: Can't load daily.ndb
    LibClamAV Error: Can't load /var/lib/clamav/daily.cld: Malformed database
    ERROR: Malformed database

    [FALLĂ“]

    I hope you have a repository to update via yum

    thanks
     
    Last edited: Apr 25, 2010
  4. falko

    falko Super Moderator ISPConfig Developer

    I don't know if there's a yum repository with the current ClamAV version (0.96). You might have to compile ClamAV yourself if you want to fix this.
     
  5. calivent

    calivent New Member

    after all this time still no one found repositories for FC10

    after all this time still no one found repositories for FC10

    someone must have found or compiled .. personally I have the ispconfig3 and there are fears that fails and then chaos
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Fedora 10 is dead, so there are no repositories for it anymore.
     

Share This Page