clamav and rspamd (centos 7)

Discussion in 'Installation/Configuration' started by Steffan, Mar 4, 2022.

  1. Steffan

    Steffan Member

    Hello i have no idee when it stopped working but i cant find out what to change toe get it working again:
    any idees what i have to change?

    override.d/antivirus.conf
    Code:
    clamav {
    timeout = 15.0;
    retransmits = 5;
    }
    
    modules.d/antivirus.conf and local.d/antivirus.conf
    has:
    servers = "127.0.0.1:3310";



    Code:
     #17857(main) <q6o6kx>; lua; clamav.lua:63: no servers defined
    #17857(main) <q6o6kx>; lua; antivirus.lua:183: cannot add rule: "clamav"
    Code:
     ps aux | grep clam
    clamupd+   919  0.0  0.0 219996  7284 ?        Ss    2021   0:34 /usr/bin/freshclam -d -c 1
    root     15587  0.0  0.0   9096   888 pts/0    S+   15:53   0:00 grep --color=auto clam
    root     18854  1.3  4.8 1441192 1225256 ?     Ssl  15:32   0:17 /usr/sbin/clamd -c /etc/clamd.d/rspamd.conf
    clamscan 21338  0.8  4.8 1441192 1225308 ?     Ssl  15:18   0:17 /usr/sbin/clamd -c /etc/clamd.d/scan.conf
    root     21556  0.0  0.0   9564  2284 ?        Ss   15:00   0:00 /bin/sh -c /usr/share/clamav/freshclam-sleep > /dev/null
    root     21571  0.0  0.0   9564  2200 ?        S    15:00   0:00 /bin/bash /usr/share/clamav/freshclam-sleep
    
    Code:
    netstat -tulpn | grep clamd
    tcp        0      0 127.0.0.1:3310          0.0.0.0:*               LISTEN      21338/clamd
    
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    I think what these 2 files have is entirely irrelevant and unused when you create an override.d/antivirus.conf. I would probably remove that override.d file (and any others you may have created, unless you absolutely know they serve the correct purpose and are needed) then reconfigure services with the ISPConfig installer and see where things are at. rspamd normally talks to clamd via the /var/run/clamav/clamd.ctl socket, not port 3310, at least on debian systems (I don't have a centos system to test that).
     
  3. michelangelo

    michelangelo Member

    On CentOS (and clones) that use the EPEL package of ClamAV, the socket file is "/run/clamd.<systemd-instance>/clamd.sock".
    I've it configured like that: "/run/clamd.scan/clamd.sock" and it works fine here.
     
  4. Steffan

    Steffan Member

    oke the problem whas override.d/antivirus.conf
    i read that file if it will add extra parameters. But it overrides all settings.

    It is fixed now
    Thanxs
     

Share This Page