ClamAV 0.94 End of Life!

Discussion in 'General' started by SamTzu, Apr 16, 2010.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    You can try this:

    apt-get install --reinstall clamav
  2. calivent

    calivent New Member

    Fedora core 10 clamav update to 0.96

    the solution of the problem is simple in debian, with a simple apt-install .... the problem is in Fedora and Centos ...
    Fedora 10 and I have no repositories for ClamAV, and I have trouble compiling its source code. someone who can contribute or have a link that explains how to do it under the platform I'm using

    the momentary and incorrect solution was to delete the file /var/lib/clamav/daily.cld and block the updating of antivirus ... runs very well so the mail, but it is not correct.
    I'm using FC10 repeat with ISPConfig
  3. Toucan

    Toucan New Member

    Thanks Till, I though I was almost there, but it returned this:
    badbuntu:~# apt-get install --reinstall clamav
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
    Need to get 0B/271kB of archives.
    After this operation, 0B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    (Reading database ... 38332 files and directories currently installed.)
    Preparing to replace clamav 0.95.3+dfsg-1~volatile1 (using .../clamav_0.95.3+dfsg-1~volatile1_i386.deb) ...
    Unpacking replacement clamav ...
    Processing triggers for man-db ...
    Setting up clamav (0.95.3+dfsg-1~volatile1) ...
    It seems it picked up version 95.3 again. I have all other repos commented out.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    0.95.3 is the correct new version, so everything has been updated fine. 0.95.3 is the latest available version from debian volatile and it fixes this problem as there are up to date antivirus databases available for this release from the clamav project.
  5. Toucan

    Toucan New Member

    Thanks Till, I was confused by ISPConfig reporting that the latest version was .96. Problem Solved..... Thanks

  6. calivent

    calivent New Member

    FEDORA aaaa 10

    whit Fedora Core 10 ?????????....

    because they do not?
  7. voltron81

    voltron81 New Member

    Of course I've the same problem...
    According with the suggestion of Till, I had a look at this link:

    The problem is that when I'll try to upgrade clamav, the server is trying to upgrade all the packages that needs to be upgraded... and at the moment I would like to upgrade just the clamav stuff... (I've for example a master-master replication and I'm quite scare to upgrade mysql...)

    There is a way to do it?
    I tried this command:
    apt-get -u upgrade clamav
    but it doesn't work...


  8. primal23

    primal23 New Member

    Having the same issue myself....
  9. ivomendonca

    ivomendonca Banned

    Just add the volatile repository to sources.list
    and run
    apt-get update
    apt-get dist-upgrade or apt-get upgrade.

    All this work i dont know where are you writing the commands but if you got permissions and a internet line is all that you need. (Lenny)

    Please update all parts of your system, mysql inclusive.
    Last edited: Apr 29, 2010
  10. Toucan

    Toucan New Member

    Debian repos update

    The following debian sources now seem to include the ClamAV upgrade to .96

    My monitor is back to appeasing green :D

    deb lenny main
    deb-src lenny main
    deb-src lenny/updates main
    deb lenny/updates main
    deb lenny/volatile main
    deb-src lenny/volatile main
    Last edited: May 2, 2010
  11. falko

    falko Super Moderator ISPConfig Developer

  12. voltron81

    voltron81 New Member

    Ok I've upgrade the system and now clamav seems to be ok.
    Anyway I can see now that the /var folder is going out of space...
    /dev/sda6	xfs	4.7G	4.2G	514M	90%	/var
    How is possible?

    How can I solve it?

  13. voltron81

    voltron81 New Member

  14. voltron81

    voltron81 New Member

    Hi to everybody.
    I'm managing 2 mailserver with ISPConfig and the configuration of both is exatly the same.
    As I said before, I've upgrade the systems, so that I don't have anymore all the email with viruses in the queue.

    In one server everything is working perfect, in the other I've notice that in Mail-err Log I can still read this error message:
    May 18 08:29:46 srv3 amavis[15714]: (15714-06) (!!)ClamAV-clamd av-scanner FAILED: run_av error: Too many retries to talk to /var/run/clamav/clamd.ctl (Can't connect to UNIX socket /var/run/clamav/clamd.ctl: No such file or directory) at (eval 100) line 309.
    So I tried to restart the clamav-daemon and I've got this error:
    srv3:/var/run/clamav# /etc/init.d/clamav-daemon restart
    Stopping ClamAV daemon: clamd.
    Starting ClamAV daemon: clamd LibClamAV Warning: ***********************************************************
    LibClamAV Warning: ***  This version of the ClamAV engine is outdated.     ***
    LibClamAV Warning: *** DON'T PANIC! Read ***
    LibClamAV Warning: ***********************************************************
    LibClamAV Error: cli_hex2str(): Malformed hexstring: This ClamAV version has reached End of Life! Please upgrade to version 0.95 or later. For more information see and (length: 169)
    LibClamAV Error: Problem parsing database at line 741
    LibClamAV Error: Can't load daily.ndb: Malformed database
    LibClamAV Error: cli_tgzload: Can't load daily.ndb
    LibClamAV Error: Can't load /var/lib/clamav/daily.cld: Malformed database
    ERROR: Malformed database
    How is possible that two twin servers with the same configurations have such a different behaviour?
    It's look like the system doesn't update the clamav-daemon...isn't it?

  15. till

    till Super Moderator Staff Member ISPConfig Developer

  16. voltron81

    voltron81 New Member

    Hi Till,
    thanks for your answer.

    It was my bad... the new repository in one server was commented out...

    Thanks a lot

Share This Page