ClamAV 0.94 End of Life!

Discussion in 'General' started by SamTzu, Apr 16, 2010.

  1. SamTzu

    SamTzu Member HowtoForge Supporter

    We have serious problem with our lenny2 servers.
    There seem to be no upgrade possible at the moment.

    Cat /etc/apt/sources.list
    LibClamAV Error: cli_hex2str(): Malformed hexstring: This ClamAV version has reached End of Life! Please upgrade to version 0.95 or later. For more information see www.clamav.net/eol-clamav-094 and www.clamav.net/download (length: 169)
    LibClamAV Error: Problem parsing database at line 742
    LibClamAV Error: Can't load daily.ndb: Malformed database
    LibClamAV Error: cli_tgzload: Can't load daily.ndb
    LibClamAV Error: Can't load /var/lib/clamav/daily.cld: Malformed database
    ERROR: Malformed database
     
  2. Hans

    Hans Moderator ISPConfig Developer

    Hi I have the same problem here.
    Same errors as you have:

    /etc/init.d/clamav-daemon start
    Starting ClamAV daemon: clamd LibClamAV Warning: ******************************* ****************************
    LibClamAV Warning: *** This version of the ClamAV engine is outdated. ***
    LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
    LibClamAV Warning: ***********************************************************
    LibClamAV Error: cli_hex2str(): Malformed hexstring: This ClamAV version has rea ched End of Life! Please upgrade to version 0.95 or later. For more information see www.clamav.net/eol-clamav-094 and www.clamav.net/download (length: 169)
    LibClamAV Error: Problem parsing database at line 742
    LibClamAV Error: Can't load daily.ndb: Malformed database
    LibClamAV Error: cli_tgzload: Can't load daily.ndb
    LibClamAV Error: Can't load /var/lib/clamav/daily.cld: Malformed database
    ERROR: Malformed database
     
    Last edited: Apr 16, 2010
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    The clamav packages are from debian and not ispconfig. As this is a general debian problem, I guess they will or have released already updates for it. So make sure that you installed all debian updates. As alternative you can e.g. use the clamav packages from the debian volatile project:

    http://www.debian.org/volatile/

    The clamav from the volatile project is 0.95.3.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. SamTzu

    SamTzu Member HowtoForge Supporter

    apt-get update and apt-get dist-upgrade do not update Clam.
    I'm trying a testserver upgrade to squeeze but so far it's not going well.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Use the volatile repository as I suggested.
     
  7. SamTzu

    SamTzu Member HowtoForge Supporter

    Debian ClamAV End of Life 0.94

    This seems to work...
    Add Volatile repository to APT list.
    I did it by editing the sources.list with vi and these commands i ZZ
    Clam install wants you to press q button.

    deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free
    <-- This line needs to be in /etc/apt/sources.list file!!!

    apt-get update
    apt-get upgrade
    /etc/init.d/amavis restart
    postsuper -r ALL
     
    Last edited: Apr 17, 2010
  8. multilan

    multilan New Member

    Same problem with Fedora Core10

    I have the same problem on Fedora Core 10. I'm not sure where to get distribution packages as I ran "yum update" for all packages but the ClamAV ones were not updated. Any tips for FC10 specifically?

    Thanks
     
  9. edge

    edge Active Member Moderator

    Not working for me :-(
    All emails are still marked with "This version of the ClamAV engine is outdated" and NOT delivered to the user.

    How do I stop messages being scanned by "amavis"?

    I've already done the
    thing, but still with no luck :-
     
    Last edited: Apr 16, 2010
  10. Hans

    Hans Moderator ISPConfig Developer

    @Edge,
    You must do this:

    add the line deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free to your /etc/apt/sources.list

    After that execute:

    apt-get update
    apt-get install clamav
    apt-get upgrade
    /etc/init.d/amavis restart
    postsuper -r ALL
     
  11. edge

    edge Active Member Moderator

    Hans I get this when doing the "apt-get install clamav"
    Dong this: apt-get install libclamav6
    gives me this:
     
    Last edited: Apr 16, 2010
  12. edge

    edge Active Member Moderator

    Okay.. Got it working.
    Problem with my system was that I could not use the "volatile.debian.org lenny/volatile/main Packages" as it was duplicated.
    Damn.. I lost a lot of email as I also did a "postsuper -d ALL"

    Greatings from Scotland this time :)
     
    Last edited: Apr 24, 2010
  13. Hans

    Hans Moderator ISPConfig Developer

    @Edge, good to hear you did it! ;)
     
  14. binaryrogue

    binaryrogue New Member

    I'm also running Fedora 10 and my mail flow just stopped regarding this issue. Any tips regarding upgrading clamav will be very helpful. In the meantime, I just commented out:

    #content_filter = amavis:[127.0.0.1]:10024

    in my main.cf file in the meantime since I have another spam/virus filter in front as first touch.

    **Better workaround for Fedora 10 - You can still keep using amavisd running to scan for spam/viruses but you won't be able to get the latest antivirus definitions. If you have a backup of daily.cld from two days ago... replace it with the the current one "/var/lib/clamav/daily.cld". Then disable the freshclam updates from "/etc/cron.d/clamav-update".

    I still would like know if anyone running Fedora 10 can get clamav upgraded to 0.95 or 0.96.
     
    Last edited: Apr 17, 2010
  15. mode

    mode New Member

    I'm facing on the same problem on my Fedora 10 as well. Help ! :(
     
  16. Toucan

    Toucan New Member

    I'm a bit confused, SamTzu didn't include the line apt-get install clamav. I already have it installed, should I include this line?
     
  17. edge

    edge Active Member Moderator

    Yes you will need to do this as you need to install the "new" clamav from "http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free"
     
  18. spikes

    spikes Member

    After I have done the upgrade and login to ispconfig. I still see this:

    warning:
    Your virus protection is OUTDATED! [More...]

    Received signal: wake up
    ClamAV update process started at Mon Apr 19 04:25:22 2010
    WARNING: Your ClamAV installation is OUTDATED!
    WARNING: Local version: 0.94.2 Recommended version: 0.96
    DON'T PANIC! Read http://www.clamav.net/support/faq
    main.cld is up to date (version: 52, sigs: 704727, f-level: 44, builder: sven)
    daily.cld is up to date (version: 10756, sigs: 52433, f-level: 51, builder: guitar)

    I thought it's upgraded now? Do I need to un-install the old ver manually and how?

    Reading package lists... Done
    server1:~# apt-get install clamav
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
    sharutils
    Use 'apt-get autoremove' to remove them.
    The following extra packages will be installed:
    libclamav6 libtommath0
    Suggested packages:
    libclamunrar6
    The following NEW packages will be installed:
    libclamav6 libtommath0
    The following packages will be upgraded:
    clamav
    1 upgraded, 2 newly installed, 0 to remove and 3 not upgraded.
    Need to get 884kB of archives.
    After this operation, 1315kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Get:1 http://ftp.nz.debian.org lenny/main libtommath0 0.39-3 [52.6kB]
    Get:2 http://volatile.debian.org lenny/volatile/main libclamav6 0.95.3+dfsg-1~vo
    latile1 [560kB]
    Get:3 http://volatile.debian.org lenny/volatile/main clamav 0.95.3+dfsg-1~volati
    le1 [271kB]
    Fetched 884kB in 6s (143kB/s)
    Reading changelogs... Done
    Selecting previously deselected package libtommath0.
    (Reading database ... 39849 files and directories currently installed.)
    Unpacking libtommath0 (from .../libtommath0_0.39-3_i386.deb) ...
    Selecting previously deselected package libclamav6.
    Unpacking libclamav6 (from .../libclamav6_0.95.3+dfsg-1~volatile1_i386.deb) ...
    Preparing to replace clamav 0.94.dfsg.2-1lenny2 (using .../clamav_0.95.3+dfsg-1~
    volatile1_i386.deb) ...
    Unpacking replacement clamav ...
    Processing triggers for man-db ...
    Setting up libtommath0 (0.39-3) ...
    Setting up libclamav6 (0.95.3+dfsg-1~volatile1) ...
    Setting up clamav (0.95.3+dfsg-1~volatile1) ...
    server1:~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages will be upgraded:
    clamav-base clamav-daemon clamav-freshclam
    3 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 24.7MB of archives.
    After this operation, 4874kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Get:1 http://volatile.debian.org lenny/volatile/main clamav-freshclam 0.95.3+dfs
    g-1~volatile1 [281kB]
    Get:2 http://volatile.debian.org lenny/volatile/main clamav-daemon 0.95.3+dfsg-1
    ~volatile1 [364kB]
    Get:3 http://volatile.debian.org lenny/volatile/main clamav-base 0.95.3+dfsg-1~v
    olatile1 [24.0MB]
    Fetched 24.7MB in 2min35s (158kB/s)
    Reading changelogs... Done
    Preconfiguring packages ...
    (Reading database ... 39868 files and directories currently installed.)
    Preparing to replace clamav-freshclam 0.94.dfsg.2-1lenny2 (using .../clamav-fres
    hclam_0.95.3+dfsg-1~volatile1_i386.deb) ...
    Stopping ClamAV virus database updater: freshclam.
    Unpacking replacement clamav-freshclam ...
    Preparing to replace clamav-daemon 0.94.dfsg.2-1lenny2 (using .../clamav-daemon_
    0.95.3+dfsg-1~volatile1_i386.deb) ...
    Stopping ClamAV daemon: clamd.
    Unpacking replacement clamav-daemon ...
    Preparing to replace clamav-base 0.94.dfsg.2-1lenny2 (using .../clamav-base_0.95
    .3+dfsg-1~volatile1_all.deb) ...
    Unpacking replacement clamav-base ...
    Processing triggers for man-db ...
    Setting up clamav-base (0.95.3+dfsg-1~volatile1) ...
    Replacing config file /etc/clamav/clamd.conf with new version
    Setting up clamav-freshclam (0.95.3+dfsg-1~volatile1) ...
    Installing new version of config file /etc/init.d/clamav-freshclam ...
    Replacing config file /etc/clamav/freshclam.conf with new version
    Starting ClamAV virus database updater: freshclam.
    Setting up clamav-daemon (0.95.3+dfsg-1~volatile1) ...
    Installing new version of config file /etc/init.d/clamav-daemon ...
    Starting ClamAV daemon: clamd LibClamAV Warning: *******************************
    ****************************
    LibClamAV Warning: *** This version of the ClamAV engine is outdated. ***
    LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
    LibClamAV Warning: ***********************************************************
    .
     
  19. spikes

    spikes Member

    I see. Thank you.

    WARNING: Local version: 0.95.3 Recommended version: 0.96
     
  20. cyberw

    cyberw New Member

    clamav 0.96 FC10 download update problem

    Hello Team,

    I too am having the clamav 0.94 FC10 problem. I am unable to locate an update using yum, and am unsure how to obtain from another location that will suit this installation.

    I have a malformed DB according to clamscan, and all updates continue to re-install 0.94.

    Live server, no mail currently. What do you need in order to assist me with this people?

    TIA, Cyberw
     

Share This Page