Chrooted SSH/SFTP need help

Discussion in 'Installation/Configuration' started by docean, Mar 13, 2008.

  1. docean

    docean New Member

    Hello, I've installed a Debian Etch base system and am following a tutorial I found on here to install ssh so i can use putty. I'm getting the following error when I run this:
    wget http://chrootssh.sourceforge.net/download/openssh-4.5p1-chroot.tar.bz2
    tar xvfj openssh-4.5p1-chroot.tar.bz2
    cd openssh-4.5p1-chroot
    ./configure --exec-prefix=/usr --sysconfdir=/etc/ssh --with-pam
    make
    make install

    error states : wget unrecognized option '--exec-prefix=/usr'

    can anyone help me with this please?

    Thank You

    dc
     
  2. Leszek

    Leszek New Member

    You can try this:
     
  3. docean

    docean New Member

    Leszek thank you for the reply, tried your suggestion now I get

    wget: unrecognized option `--prefix=/usr'

    what should i try next?

    dc
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Leszek doesn't want you to change the wget command. What he means is: change this command:
    Code:
    ./configure --exec-prefix=/usr --sysconfdir=/etc/ssh --with-pam
    to this one:
    Code:
    ./configure --prefix=/usr --sysconfdir=/etc/ssh --with-pam
     
  5. docean

    docean New Member

    thank you for the reply falko I've ditched this install and started over I have used your Perfect Server tutorial for Debian Etch and also installed ISPConfig and all has went well...thank you. I'm having a problem though with logging into my pop3 server from my windows xp client using outlook. Should I start a new thread or post the last 100 lines from /var/log/mail.log here?

    thanks again!

    dan
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Start a new thread and post the errors from your mail log there. :)
     

Share This Page