chrooted ssh guide killed perforce

Discussion in 'Server Operation' started by v2k, Dec 31, 2008.

  1. v2k

    v2k New Member

    I tried following this guide to setup chrooted ssh:

    I tried manual and script methods. I was never able to get it to work. I never touched my 'perforce' user, but now I am unable to connect to my perforce server running on the same machine.


    I have no idea where to start. The p4d is running and I can ssh into the box.
  2. v2k

    v2k New Member

    My bad, turning off iptables gets around this. I know I didn't touch iptables at all, but I don't see how this could be related to the ssh stuff I was playing with.
  3. v2k

    v2k New Member

    These iptables look totally foreign to me aside from opening port 22 and 80, have I been hacked? Or is this normal... means nothing to me.

    ]$ sudo cat /etc/sysconfig/iptables
    # Firewall configuration written by system-config-firewall
    # Manual customization of this file is not recommended.
    :INPUT ACCEPT [0:0]
    :OUTPUT ACCEPT [0:0]
    -A INPUT -p icmp -j ACCEPT
    -A INPUT -i lo -j ACCEPT
    -A INPUT -m state --state NEW -m udp -p udp --dport 5353 -d -j ACCEPT
    -A INPUT -m state --state NEW -m udp -p udp --dport 137 -j ACCEPT
    -A INPUT -m state --state NEW -m udp -p udp --dport 138 -j ACCEPT
    -A INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT
    -A INPUT -m state --state NEW -m tcp -p tcp --dport 80 -j ACCEPT
    -A INPUT -j REJECT --reject-with icmp-host-prohibited
    -A FORWARD -j REJECT --reject-with icmp-host-prohibited
  4. falko

    falko Super Moderator ISPConfig Developer

Share This Page