chroot shell jailkit not working after update to 3.2

Discussion in 'General' started by jonathannet, Oct 15, 2020.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    Which jailkit version do you use? Maybe it makes sense to update jailkit to the current version if it#s not the current one.
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Well, other than the above suggestions (which you have or haven't done?), I can think of other ways to trigger the jail to be rebuilt (eg. add /usr/lib/openssh/sftp-server to 'Jailkit chrooted applications' then change your shell user back to Jailkit mode, and run server.sh manually at debugging log level), but if you actually have done that, you might have an error in your jk_init.ini, you could try using the one that ships with ISPConfig, or even post the one you do have and the output from your jk_init commands.
     
    till likes this.
  3. buhler

    buhler Member

    I have the same problem.
    Debian 9 with jailkit 2.19.
    Debian 10 with jailkit 2.20
     
    Last edited: Nov 10, 2020
  4. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Trigger the jail to rebuild using the above steps and run server.sh in debug mode, what does it show happening/failing and errors?
     
  5. buhler

    buhler Member

    I deleted the shell user. Then I deleted the contents of the bin, var, usr, etc. Then I created the user again and it worked
     

Share This Page