check_phpini_changes every single minute

Discussion in 'General' started by MitchTalmadge, Jun 15, 2016.

  1. MitchTalmadge

    MitchTalmadge New Member

    Hi, I'm receiving this in my logs every minute of every hour, running on ISPConfig 3.1b1:

    DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock

    Why might this be happening? I remember trying to add an "auto_prepend_file" setting to my php.ini for one of my websites because Wordfence (A WordPress security plugin) told me to do so, however that never ended up working and I have removed it since then.

    These are the only settings I've used on my websites:

    upload_max_filesize=20M
    post_max_size = 20M
    memory_limit=256M
    log_errors = on

    Thanks!
     
  2. Jesse Norell

    Jesse Norell Active Member

    Just guessing, but do you have a .vhost.err file showing up under /etc/apache2/sites-enabled/ ?

    If it helps, I recently ran through setting up the wordfence firewall in all php modes on ispconfig 3.1 - you only need that auto_prepend_file statement for hhvm, the .user.ini file works fine for fastcgi and php-fpm.
     
  3. MitchTalmadge

    MitchTalmadge New Member

    Not in sites-enabled, but I do in sites-available. How can I find out what the error is? I am using hhvm, I forgot to mention. That is the reason I tried to add the statement, however it had no effect.

    Edit: I just renamed my vhost to vhost.bak and vhost.err to vhost, restarted apache2, and checked the logs; no errors. The website works fine. No idea why the err file was even generated...
     
    Last edited: Jun 16, 2016
  4. MitchTalmadge

    MitchTalmadge New Member

    It appears that the server.php file is being run every single minute, which forces a reload of every plugin. Is this intended behavior?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, that's the correct behaviour. Just set the log level back to the warning or error level.
     

Share This Page