Changing URL address to my squirrelmail

Discussion in 'Installation/Configuration' started by belmont, Jul 28, 2009.

  1. belmont

    belmont New Member

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Create a website webmail.mydomain.com and install a copy of squirrelmail into this website.
     
  3. belmont

    belmont New Member

    Thanks.. It works...

    Belmont
     
  4. belmont

    belmont New Member

    Ok I got the Squirrelmail login, but I am not able to login.

    This is what I did after creating a new site webmail.Mydomain.com

    1) I check the boxes of PHP Scripts and Mailuser login
    2) I create a new account through my terminal
    useradd -s /sbin/nologin newuser
    passwd newuser
    3) I create a new email account in ISP Manager / MyMainSite / Site Management - host (webmail) - User&Email called newuser
    4) I send a email called Welcome to [email protected]. I did verified that the email did arrive in /var/www/web9/web/newuser/Maildir/new folder

    I use the same username and password that I use when creating the account with useradd.

    My /var/log/mail.info said

    Jul 28 15:07:35 server2 imapd: LOGIN FAILED,
    [email protected], ip=[::ffff:127.0.0.1]
    Jul 28 15:07:40 server2 imapd: LOGOUT, ip=[::ffff:127.0.0.1],
    rcvd=60, sent=332
    Jul 28 15:07:43 server2 imapd: LOGOUT, ip=[::ffff:127.0.0.1],
    rcvd=30, sent=470

    I have 2 sites under MyMainSite. I have www and webmail. I follow the same process in www site and webmail site. I only can log into www site which is https://www.Mydomain.com:81/squirrelmail/src/login.php. The reason I created the webmail site so that is will be easier to get into squirrelmail. webmail.Mydomain.com

    Why I can log into email account I created in www but not webmail sites?

    Help please
    Belmont
     
  5. falko

    falko Super Moderator ISPConfig Developer

    If you use the normal SquirrelMail package for your webmail site, you must log in with the correct username, e.g. web1_username, instead of using the email address. The SquirrelMail package for ISPConfig was patched to allow email addresses for the login.
     
  6. belmont

    belmont New Member

    I am aware of that. I remove the setting in Management - System Config - Settings - ISP Manager - User Prefix Web[WEBID]_ setting so I do not have to put web10_username. I am able to log into the squirrelmail at https://www.Mydomain.com:81/Squirrelmail/src/login.php only, but not webmail.Mydomain.com site.

    I removed my 2 sites www and webmail and my Client Account. Empty my trash bin. Then I put back the Management - System Config - Setting - ISP Manager - User Prefix Web[WEBID]_ setting. I then recreate the Client Account and my 2 sites www and webmail. This time I have to use web11_username to log into Squirrel mail. I can log into the https://www.Mydomain.com:81/Squirrelmail/src/login.php, but not webmail.Mydomain.com.

    I would like to use the webmail.Mydomain.com to log into the squirrel mail because its easier and cleaner. I am sure this is possible.

    Any Idea?
    Belmont
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    The username prefix has nothing to do with the webmail URL.

    Sure, and the answer is still #2 of this thread.
     

Share This Page