Changing to SSL for ISPconfig site.

Discussion in 'Installation/Configuration' started by Rockdrala, Dec 31, 2007.

  1. Rockdrala

    Rockdrala New Member

    I installed and selected http:// instead of https://

    How do i switch back to the https://

    and will this affect any of the hosted sites or the ip address there on.
     
  2. edge

    edge Active Member Moderator

  3. Rockdrala

    Rockdrala New Member

    didnt work.

    This does not work. I did it twice to be sure.

    There must be a way to put the ISPconfig pages back on ssl.

    Doing this does put the default page on ssl on a default certificate from localhost. but it doesnt make ispconfig accessible on https.

    Its still accesible http:// and returns page cannot be found on https://

    and even now certain modules arent accessible in ispconfig like server settings. Gives a page cannot be found in the control panel.
     
    Last edited: Jan 1, 2008
  4. Rockdrala

    Rockdrala New Member

    wtb link

    Can someone link or post there SSL version of the config.inc.php so i can see what setting is missing here.

    Apparently this is generated by the initial install so there must be some setting im missing for https
     
  5. Rockdrala

    Rockdrala New Member

    The reason im trying to to put it back as SLL

    The CURL is calling for a SSL page at /remote/index.php

    the CURL returns a SSL error when i try to uncomment the get resseller list in the test.php example.


    Error: HTTP Error: cURL ERROR: 35: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol
    url: https://mywebsitehere.com:81/remote/index.php
    http_code: 0
    header_size: 0
    request_size: 0
    filetime: -1
    ssl_verify_result: 0
    redirect_count: 0
    total_time: 0
    namelookup_time: 0.107529
    connect_time: 0.107721
    pretransfer_time: 0
    size_upload: 0
    size_download: 0
    speed_download: 0
    speed_upload: 0
    download_content_length: 0
    upload_content_length: 0
    starttransfer_time: 0
    redirect_time: 0


    Now if i make https:// http:// in the script all i get is

    Script end ...

    Now i can verify from phpinfo that curl is working in php. Must it have SSL to work?

    And how can i revert back to SSL. The above instructions do not work.
     
  6. falko

    falko Super Moderator ISPConfig Developer

  7. Rockdrala

    Rockdrala New Member

    I have verified this works for http.

    I have verified this works for reverting to http.
    I have also verified this does not work for reverting to https://

    Theres something being missed. I need to see a ssl config to verify whats missing. maybe ill throw together another box soon to find out.
     

Share This Page