changing ssh and ispconfig ports

Discussion in 'Installation/Configuration' started by psychop, Nov 11, 2011.

  1. psychop

    psychop New Member

    Hi.
    Changed default ports for ssh and ispconfig. Ssh changed to 2260 and ispconfig to 8060. Ports are also changed in bastille-firewall.cfg so when I run bastille from terminal it all works great.
    Problem starts when I enable firewall in ISPConfig, because ports are not changed here, they are sill 22 and 81. When I start firewall from ISP Services (settings) it changes ports in bastille-firewall back to what it's written here in ISPConfig (from 2260 to 22 and 8060 to 81) and my access is blocked from outside.
    SO to question: How to change this 2 ports in ISPConfig settings?

    TNX all
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Just add the new ports in the firewall settings in ispconfig. Dont edit bastille-firewall.cfg manually as all changes get removed automatically.
     
  3. psychop

    psychop New Member

    Ok. tnx for quick reply.
    One more question... Any idea how to change postfix listen on other port than 25? Added 8499 infront of smtpd and still not working. also added this port to iptables and changed it in iscpnofig conf file check_smtp '127.0.0.1' port 8499 and it says it is offline and can't telnet...
     
  4. psychop

    psychop New Member

    SOlved the problem ;)
     
  5. testpress

    testpress New Member

    hi, i changed the firewall ports via the web client (ispconfig control panel) and now nothing is working. Ive tried to change the bastille.cfg file but blocks all the ports again once the server is 100% up. How do i change this via command line to undo my changes?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

Share This Page