Changing Roundcube port?

Discussion in 'Installation/Configuration' started by crypted, Jun 5, 2008.

  1. crypted

    crypted New Member

    Currently, to access Webmail via roundcube, I have to go to http://server:81/roundcube/. Unfortunately, most of the locations I try to access webmail block any ports that aren't 80. Is there any way to have Roundcube run from a specific address under port 80 instead of 81, or even having it run on both ports if necessary?

  2. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Well what I did was to NAT port 8443 and 8080 to 81, so I do not need to change anything.
    But I would not know how to implement this with the ISP-Config shipped iptables stuff, I never use it, instead I use firehol (

    Beside this, you can also install firehol yourself and serve it with the "normal" apache running on port 80, that's what I did in the end.
    Created an SSL-Reverse proxy web with that I access my webmail, phpmyadmin and so on.
  3. crypted

    crypted New Member

    interesting... any idea how I would go about making firehol work in this instance? what did you do for its settings to get it to do as you needed?
  4. radim_h

    radim_h Member HowtoForge Supporter

    you can also create new site in ISPC for example webmail.yourdomain.tld
    and copy existing roudcube in there from /home/admispconfig/ispconfig/web/roundcubemail
  5. crypted

    crypted New Member

    Okay, I copied that data over. Now, the page doesn't fully load.

    The theme of the ROUNDCUBE page loads, but it just says the following instead of giving the login information form:


    Unable to connect to the database!
    Please contact your server-administrator.

    I'm wondering if it comes from this setting in the
    $rcmail_config['db_dsnw'] = 'sqlite://./sqlite.db?mode=0646';

    The sqlite DB is there in the new directory just as it was in the other...
  6. Hans

    Hans Moderator ISPConfig Developer

Share This Page