changing rooter problems

Discussion in 'Installation/Configuration' started by shajazzi, May 29, 2006.

  1. shajazzi

    shajazzi Member

    Hi, I have suse 9.3 and ispconfig that was running OK until i tried changing my router box.
    Accesss through the router box was 192.168.2.1, the new box access is 192.168.1.254.
    In yast under Router configuration i change the settings from 192.168.2.1 to 192.168.1.254
    I also change all the relevant setting in Ispconfig.
    All the sites are running OK but i cannot access Webmail also I get this ERROR when trying to restart apache.
    # /etc/init.d/apache2 restart
    Syntax error on line 108 of /etc/apache2/default-server.conf:
    Invalid command 'SSLEngine', perhaps mis-spelled or defined by a module not included in the server configuration
    Thanks in advance

    shajazzi
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/resolv.conf?
     
  3. shajazzi

    shajazzi Member

    Thanks falko,
    This is what i have in /etc/resolv.conf


    ### BEGIN INFO
    #
    # Modified_by: dhcpcd
    # Backup: /etc/resolv.conf.saved.by.dhcpcd.eth0
    # Process: dhcpcd
    # Process_id: 15467
    # Script: /sbin/modify_resolvconf
    # Saveto:
    # Info: This is a temporary resolv.conf created by service dhcpcd.
    # The previous file has been saved and will be restored later.
    #
    # If you don't like your resolv.conf to be changed, you
    # can set MODIFY_{RESOLV,NAMED}_CONF_DYNAMICALLY=no. This
    # variables are placed in /etc/sysconfig/network/config.
    #
    # You can also configure service dhcpcd not to modify it.
    #
    # If you don't like dhcpcd to change your nameserver
    # settings
    # then either set DHCLIENT_MODIFY_RESOLV_CONF=no
    # in /etc/sysconfig/network/dhcp, or
    # set MODIFY_RESOLV_CONF_DYNAMICALLY=no in
    # /etc/sysconfig/network/config or (manually) use dhcpcd
    # with -R. If you only want to keep your searchlist, set
    # DHCLIENT_KEEP_SEARCHLIST=yes in /etc/sysconfig/network/dhcp or
    # (manually) use the -K option.
    #
    ### END INFO
    #
    search englandshirt.com englandshirt.com
    nameserver 192.168.1.254

    shajazzi
     
  4. shajazzi

    shajazzi Member

    i`ve just noticed that BIND server is no running.
    Surely these simply changes should`t cause all these problems.

    shajazzi
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Does your router (192.168.1.254) run a name server?
    Can you try
    Code:
    nameserver 145.253.2.75
    nameserver 193.174.32.18
    nameserver 194.25.0.60
    instead of
    Code:
    nameserver 192.168.1.254
     
  6. shajazzi

    shajazzi Member

    No my router dosn`t run a name server.
    I tryed adding as you suggested to /etc/resolv.conf but things remain the same.

    ### BEGIN INFO
    #
    # Modified_by: dhcpcd
    # Backup: /etc/resolv.conf.saved.by.dhcpcd.eth0
    # Process: dhcpcd
    # Process_id: 30957
    # Script: /sbin/modify_resolvconf
    # Saveto:
    # Info: This is a temporary resolv.conf created by service dhcpcd.
    # The previous file has been saved and will be restored later.
    #
    # If you don't like your resolv.conf to be changed, you
    # can set MODIFY_{RESOLV,NAMED}_CONF_DYNAMICALLY=no. This
    # variables are placed in /etc/sysconfig/network/config.
    #
    # You can also configure service dhcpcd not to modify it.
    #
    # If you don't like dhcpcd to change your nameserver
    # settings
    # then either set DHCLIENT_MODIFY_RESOLV_CONF=no
    # in /etc/sysconfig/network/dhcp, or
    # set MODIFY_RESOLV_CONF_DYNAMICALLY=no in
    # /etc/sysconfig/network/config or (manually) use dhcpcd
    # with -R. If you only want to keep your searchlist, set
    # DHCLIENT_KEEP_SEARCHLIST=yes in /etc/sysconfig/network/dhcp or
    # (manually) use the -K option.
    #
    ### END INFO
    #
    search englandshirt.com
    nameserver 145.253.2.75
    nameserver 193.174.32.18
    nameserver 194.25.0.60

    Iknow from past experience that if I stop apache things will really get messed up and will end up reinstalling everything again as I have many times before.

    shajazzi
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Does /etc/sysconfig/apache2 look like suggested on http://www.howtoforge.com/perfect_setup_suse_9.3_p5 ?
     
  8. shajazzi

    shajazzi Member

    Thanks falko,
    No it is different, it has now the folowing entry

    APACHE_MODULES="access actions alias auth autoindex cgi dir include log_config mime negotiation setenvif status userdir asis imap"

    So I changed it to:

    APACHE_MODULES="access actions alias auth auth_dbm autoindex cgi dir env expires include log_config mime negotiation setenvif ssl suexec userdir php4 php5 rewrite"

    Now I can restart Apache OK.
    But BIND server is offline and still cannot log into webmail.


    shajazzi
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Do you get error messages when you restart BIND? What's in your log files?
     
  10. shajazzi

    shajazzi Member

    I`ve now decided to reuse my old router box until I can find an easy way to swap them without all these problems, or is it something I did wrong.

    I again had to make all the changes you suggested and BIND restarts ok, the only thing that isn`t working is webmail. The login fails, these are the following mail logs.

    May 30 23:59:05 mail postfix/postfix-script: starting the Postfix mail system
    May 30 23:59:05 mail postfix/master[13563]: daemon started -- version 2.2.1, configuration /etc/postfix
    May 31 00:02:32 mail pop3d: Connection, ip=[::ffff:88.105.11.138]
    May 31 00:02:37 mail pop3d: LOGIN FAILED, ip=[::ffff:88.105.11.138]
    May 31 00:02:37 mail pop3d: Connection, ip=[::ffff:88.105.11.138]
    May 31 00:02:42 mail pop3d: LOGIN FAILED, ip=[::ffff:88.105.11.138]
    May 31 00:02:43 mail pop3d: Connection, ip=[::ffff:88.105.11.138]
    May 31 00:02:48 mail pop3d: LOGIN FAILED, ip=[::ffff:88.105.11.138]
    May 31 00:02:48 mail pop3d: Connection, ip=[::ffff:88.105.11.138]
    May 31 00:02:53 mail pop3d: LOGIN FAILED, ip=[::ffff:88.105.11.138]
    May 31 00:06:23 mail postfix/smtpd[13842]: warning: connect to private/tlsmgr: No such file or directory
    May 31 00:06:24 mail postfix/smtpd[13842]: warning: connect to private/tlsmgr: No such file or directory
    May 31 00:06:24 mail postfix/smtpd[13842]: warning: problem talking to server private/tlsmgr: No such file or directory
    May 31 00:06:24 mail postfix/smtpd[13842]: warning: no entropy for TLS key generation: disabling TLS support
    May 31 00:06:24 mail postfix/smtpd[13842]: connect from localhost[127.0.0.1]
    May 31 00:07:07 mail postfix/smtpd[13842]: disconnect from localhost[127.0.0.1]

    shajazzi
     
  11. falko

    falko Super Moderator ISPConfig Developer

    Does it work with a normal email client like Thunderbird or Outlook?
    Do you use the correct username and password?
     
  12. shajazzi

    shajazzi Member

    This is the following error i get when sending emails from Thunderfid to a webmail client:

    This is the Postfix program at host mail.yyyy.com.

    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.

    For further assistance, please send mail to <postmaster>

    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.

    The Postfix program

    <web1_steve@mail.xxxx.com> (expanded from <steve@xxxx.com>):
    unknown user: "web1_steve"



    Reporting-MTA: dns; mail.yyyy.com
    X-Postfix-Queue-ID: B1A8C49288
    X-Postfix-Sender: rfc822; shajazzi@tiscali.co.uk
    Arrival-Date: Wed, 31 May 2006 22:35:34 +0100 (BST)

    Final-Recipient: rfc822; web1_steve@mail.yyyy.com
    Original-Recipient: rfc822; steve@xxxx.com
    Action: failed
    Status: 5.0.0
    Diagnostic-Code: X-Postfix; unknown user: "web1_steve"

    Yes i am using the correct user name and password (web1_steve).

    thanks
    shajazzi
     
    Last edited: Jun 1, 2006
  13. falko

    falko Super Moderator ISPConfig Developer

    Does web1_steve exist in /etc/passwd?
     
  14. shajazzi

    shajazzi Member

    Yes falko, it contains the followin line:
    web1_steve:x:10001:10001:steve:/srv/www/web1/user/web1_steve:/bin/bash

    shajazzi
     
  15. falko

    falko Super Moderator ISPConfig Developer

    Make sure that mail.xxxx.com is pointing to the correct IP address (i.e., your server). Maybe it is currently pointing to another server which obviously doesn't know web1_steve...
     

Share This Page