Changing IP for ISPConfig

Discussion in 'Installation/Configuration' started by virtue, Oct 30, 2009.

  1. virtue

    virtue New Member


    I have successfully installed ISPConfig with Centos 5.3. I just have some minor problems such as:

    ~rkhunter is skipping scanning of MD5; it cannot identify my webserver's O/S.
    ~ClamAv doesn't update correctly. It's giving me a warning that clamav is outdated. HOw can I upgrade it? Can I do it under yum?
    ~I do not get ISPConfig system log, no mail error log, no update or monitoring of any addons either.
    ~I cannot receive emails from my squirrelmail. As for squirrelmail, how do I upgrade it to the latest version?

    Also, if I want to change the IP of my webserver, how can I do it without stopping the service of ISPConfig 3?

    I certainly appreciate any genius help.

  2. wxman

    wxman New Member

    I also just upgraded to on an Ubuntu 8.04 server, and my clamAV is still showing 0.94.2.
  3. virtue

    virtue New Member

    More Assistance please

    I need more input that that.


  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Clamav is from your linux distribution and not from ispconfig. So your clamav version is not related to the ispconfig version or update.

    Install ubuntu updates with:

    apt-get update
    apt-get -u upgrade

    to get the latest available calamv version for ubuntu. You can ignore the outdated errors from clamav when you installed all ubuntu updates, the errors are misleading as clamav is not outdated, there is just a newer evsrion of the software while the signatures are up to date.
  5. till

    till Super Moderator Staff Member ISPConfig Developer


    rkhunter --update

    just install updates with yum and ignore any further errors as clamav signatures are up to date then.

    Then ispconfig is not fully installed on your system. Please make sure that you installed your system exactly as described in the perfect server guide before you install ispconfig.

    This is not related to the squirrelmail version. Solve the problem above by correcting your installation.
  6. wxman

    wxman New Member

    Thanks Till, I thought that's how it works, but I noticed clamAV listed in the ISPC update. Ubuntu still hasn't added the latest version to the repository for some reason. By the time they do, it will probably be outdated.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    You mix up ispconfig 2 and 3.

    In ISPConfig 2, clamav is part of ispconfig but not in ispconfig 3. ISPConfig 2 and 3 are completely different software packages.
  8. virtue

    virtue New Member

    Installation with ISPConfig 3

    Okay, thanks for those input Till.

    You see my webservers are i386 computers. All the Centos guide installation for ISPConfig are all for 86_64--Except for Centos 5.2. So when I made my installation, I find them perfectly fine instead of those. I kind of mix Centos 5.2 and 5.3 86_64.

    Why don't you guys give guides for i386 too? People would appreciate it if you can include it too.

    Also, with my other webserver, when I upgraded to 5.4 i386, I cannot install webalizer, amavisd-new, clamav, and clamd. I have to do it manually and I have to go through a lot of manual installation of missing perl dependencies before amavisd, clamav and clamd were installed. I end up doing another fresh install of 5.3 which is such a pain in the neck after I already made it work.

    Like for instance Clamav, when I downloaded the version to Centos 5.4, I cannot do an /etc/init.d/clamd restart because it gave me this error: missing directory. When I run clamd, it gave me this error message too advising me to change the clamd.conf configuration; error because the system cannot parse clamd.conf. I read manual 5 of clamd.conf, after I placed # with Example in the clamd.conf, it did run but, freshclam doesn't give an input on the log... which I don't know why. I started, amavisd was running okay but why it's not give proper logging.

    Anyway, I hope you guys can give some insights on these too.

  9. till

    till Super Moderator Staff Member ISPConfig Developer

    The problems that you describe are common for centos and thats why I dont use it on my servers. Centos has very few packages in its repositorys and so lacks a lot of software which has to be compiled manually. If you want to have a very stable production system where you can upgrade LThe Linux system even to new major versions of the linux distribution without messing up your system, then use debian instead of centos. With debian, you dont have to compile any packages as debian offers many more packages from its repositorys then e.g. centos.
  10. virtue

    virtue New Member



    Well, I find complicated to install Debian. I tried last time with my other server and I got stuck with the disc partitioning. It keeps on giving me errors that there is no root partition... I followed the manual guide and still it won't let me. So I abandon Debian (I was using the latest version of version of Debian). That's why I switched back to Centos 5.4.

    Well, I was able to reinstall Centos 5.3 and upgraded it to 5.4. The only thing that I am not seeing is the ISPconfig system log. I followed the guide provided here in your website using 5.4 86_64 to the letter and just change the rpm forge to that of i386. So I don't know what am I missing when it comes to installation.

    The problem now that I have is that I cannot access squirrelmail and with the other servers, I cannot receive emails but I can send emails. I have been searching high and low the internet and so far I didn't see any good guides yet... Unless you guys have additional insights to provide to fix this issues. I would definitely appreciate that.

    Thanks again.

Share This Page