Changing Document Root in ISPconfig does not work 100%

Discussion in 'Installation/Configuration' started by trymbill, Dec 18, 2007.

  1. trymbill

    trymbill New Member

    Hi everyone!

    I have a problem with my ISPconfig. I'm using it for a development server mainly for testing so I'm not afraid of messing around with it :)

    I have a Ubuntu 7.10 running and I set it up with the "Perfect Ubuntu 7.10 setup" and installed ISPconfig straight after. ISPconfig works great ... I've got everything running smoothly but my problem is that the hard drive I'm using doesn't have a lot of space left on it. I do though have another hard drive that has around 200 GB's left so I would like to use that hard drive for my Document Root. So I just want to move the /var/www folder to /media/sda/var/www and I already did so, worked fine. After that I changed the "Document Root" in ISPconfig under Management -> Settings -> Web and I can see both in the Vhosts_ispconfig.conf files that ISPconfig changed the Document Root there.

    My problem is though, that Apache seems to skip this change and is still trying to retrieve the files from /var/www ... I've tried restarting Apache, force-reloading but it doesn't seem to work. The HTTPD.conf file in /etc/apache2 is empty so I can't declare the DocumentRoot there ...

    How can I make this work? Please, somebody help me! :)
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There are two solutions:

    a) Make a symlink from /var/www to /media/sda/var/www

    b) Execute the following SQL statements in the ISPConfig database:

    update isp_isp_user set status = 'u' where status = '';
    update isp_isp_web set status = 'u' where status = '';

    and then change a setting of one of your websites in the ispconfig interface and click on save.
  3. trymbill

    trymbill New Member

    Thank you for your reply till ...

    ... I tried the second option but when I tried to change the "Document Root" under Management -> Settings -> Web ... ISPconfig changes it to "/home/admispconfig/ispconfig/web/multidoc/edit" no matter how often I try :)

    Do you know why it's doing that and how I can fix it? :- /
  4. trymbill

    trymbill New Member

    I even tried to make a Symlink from /var/www to /media/sda/var/www but then ISPconfig just changes the Document Root to "/home/www" ... I don't understand why it's doing that? :S
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Then your new document root has the wrong permissions. Please make sure that the new document root has the exact same owner and permissions then the old one.

Share This Page