Changing DB to local + backing up

Discussion in 'Installation/Configuration' started by zkvvoob, Apr 29, 2015.

  1. zkvvoob

    zkvvoob Member

    I just noticed that only two of the 10 MySQL databases configured on my server are listed as not-remote-accessible and only these have the name of the server in the corresponding column "Server". Coincidentally, only these two are backed-up by the automatic feature available in the Backup page of a website.
    When I open the configuration of a remote-accessible DB, the name of the server IS there; but try as I may, I cannot get it not to be remotely accessible - i.e. even if I unclick the "Remote Access" box AND clear the "Remote Access IPs" field, when I click "Save" nothing is changed.
    So here are my questions:
    - is there a real connection between a DB being remotely accessible and it not being backed-up?
    - how do I get all DBs to be local so that it can be backed-up?

    Thank you!
  2. till

    till Super Moderator Staff Member ISPConfig Developer


    The most likely reason for your problem is that there is no website selected yet for the database, only databases that have a website selcted get include din the website backup. Try to select the website in the database settings and press save.
  3. zkvvoob

    zkvvoob Member

    All DBs have both a website AND a server selected in their settings - or at least that's how it appears in the config page. In the overview table, the website columns are also filled with the corresponding website. However, only two DBs have a server name in that column.
    Any suggestions?

    Here are two pictures showing the overview table and a single DB's config page:
    Last edited: Apr 29, 2015
  4. zkvvoob

    zkvvoob Member

    I've retried to alter the settings, but nothing seems to do the trick. I also noticed that phpMyAdmin dsiplays some errors, could it be that they are the reason for that?
    $cfg['Servers'][$i]['pmadb'] ...    not OK [ Documentation ]
    $cfg['Servers'][$i]['relation'] ...    not OK [ Documentation ]
    General relation features: Disabled
    $cfg['Servers'][$i]['table_info'] ...    not OK [ Documentation ]
    Display Features: Disabled
    $cfg['Servers'][$i]['table_coords'] ...    not OK [ Documentation ]
    $cfg['Servers'][$i]['pdf_pages'] ...    not OK [ Documentation ]
    Creation of PDFs: Disabled
    $cfg['Servers'][$i]['column_info'] ...    not OK [ Documentation ]
    Displaying Column Comments: Disabled
    Browser transformation: Disabled
    $cfg['Servers'][$i]['bookmarktable'] ...    not OK [ Documentation ]
    Bookmarked SQL query: Disabled
    $cfg['Servers'][$i]['history'] ...    not OK [ Documentation ]
    SQL history: Disabled
    $cfg['Servers'][$i]['designer_coords'] ...    not OK [ Documentation ]
    Designer: Disabled
    $cfg['Servers'][$i]['recent'] ...    not OK [ Documentation ]
    Persistent recently used tables: Disabled
    $cfg['Servers'][$i]['table_uiprefs'] ...    not OK [ Documentation ]
    Persistent tables' UI preferences: Disabled
    $cfg['Servers'][$i]['tracking'] ...    not OK [ Documentation ]
    Tracking: Disabled
    $cfg['Servers'][$i]['userconfig'] ...    not OK [ Documentation ]
    User preferences: Disabled
    Any help would be appreciate it.
    Thank you!
    Last edited: Apr 30, 2015

Share This Page