Changing basedir outside the web interface

Discussion in 'Installation/Configuration' started by poisonborz, Mar 1, 2011.

  1. poisonborz

    poisonborz New Member

    Hola,
    I'm new to ispconfig - I tried to change the basedir, but of course messed it up, and now I can't log in to the web interface.
    Where can I find a config file where I can set back /var/www ?
    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You can not set the open_basedir in ispconfig for the ispconfig web interface. So you must have changed something else which caused the login problem.

    Which exact error message do you get?
     
  3. poisonborz

    poisonborz New Member

    What I did was System > Server Config > and after selecting server, on the Web tab, I changed website basedir, path and symlinks (in each line I replaced /var/www with a different path). Naturally after this change the web interface was not loaded with "unable to connect".

    Not much later I realized this was completely unnecessary as I can achieve my goal much easier by loading /var/www with "mount --bind" in the desired directory (the one I changed the path to earlier). But after doing this, the "unable to connect" message remained. The I've also tried to copy the contents (with working symlink in the case of the ispconfig folder) but had still no success.

    I solved the problem by reinstalling ispconfig, but the question still remains: after a failed basedir/path/symlink change, is there a way to reset this setting in the database or in a config file?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You will have to look into the ispconfig vhost file in /etc/apache2/sites-enabled/ and correct the paths. It might also be nescessary to correct symlinks in /var/www and in the clinets directories and you will have to replace the path in the server table in the ispconfig database.
     

Share This Page