Changing address for squirrelmail

Discussion in 'HOWTO-Related Questions' started by simple69, May 15, 2009.

  1. simple69

    simple69 New Member

    Hello,

    Sorry if this has been covered before but I have googled and search here for the answer already...

    I followed falkos great guide on setting up my mail system. Awesome guide everything works great as is.

    http://www.howtoforge.com/virtual-users-domains-postfix-courier-mysql-squirrelmail-ubuntu8.10

    I am trying to change the address for squirrel mail so that my users can type in http://webmail.theirdomain.com/ instead of having to use http://www.theirdomain.com/squirrelmail/ I have ready many pages today and can't get one of them to work. I am pretty sure it has something to do with the squirrelmail.conf file falko had us copy to the apache2/conf.d folder but I am not sure. I tried enabling the virtual host and using ServerAlias webmail.* but that does not seem to work.

    Any help would be appreciated . I am working with Ubuntu 8.10. Thanks ;)
     
  2. simple69

    simple69 New Member

    bump
    still looking for help
     
  3. falko

    falko Super Moderator

    How did you modify squirrelmail.conf?
    Did you create a DNS record for the webmail subdomain?
     
  4. simple69

    simple69 New Member

    thanks for the reply. I uncommented the section for the virtual host
    and added the ServerAlias webmail.* that is sort of what it said in there to do. I am not sure how or were I would create a DNS record for webmail.domain.com. Could you point me in the right direction or maybe I am going at this all wrong and you have a better way. :) would appreciate your help further.
     
  5. falko

    falko Super Moderator

    Please check if there's a DNS record for webmail.domain.com:
    Code:
    dig webmail.domain.com
    If not, you have to create one on the authoritative nameservers for domain.com which you can find out like this:
    Code:
    dig ns domain.com
     
  6. simple69

    simple69 New Member

    Thanks falko that led me in the right direction. I created the DNS record for webmail on my hosting site and then for some reason i had to change the ServerName field to webmail.domain.com for it to work. The ServerAlais entry does not seem to work for some reason. Anyways it is working now just fine. Thanks again for your help. :)

    Also thanks again for a great guide. Yours has been far the easiest to follow and it actually works. :)
     

Share This Page