Changed router - no sites

Discussion in 'Installation/Configuration' started by malder, Aug 31, 2007.

  1. malder

    malder New Member

    I had a router die last night. Changed it out and tried to configure the firewall properly (ssh, ispconfig, http ports open). When I forward port 80 to the server all my sites resolve, but the only thing that comes up is the directory listing of my /var/www.

    The only thing that has changed on the server is the /etc/networking/interfaces IP address and gateway.

    Any reason this would be? Something with apache's virtual hosts? Since these are the only changes, what could be wrong?

    I was on a roll, too... uptime was approaching a year!
     
  2. malder

    malder New Member

    Update

    ISPConfig is updating the Vhost*config file just fine. It appears that apache just isn't using it. It just goes to the default /var/www.

    The last line in /etc/apache2/apache2.conf is:

    Code:
    Include /etc/apache2/vhosts/Vhosts_ispconfig.conf
    
    Shouldn't that do it?

    I also have this:

    Code:
    Include /etc/apache2/sites-enabled/
    
    Is that anything to worry about?

    What is it that would normally make apache use the ISPConfig vhost file? :confused:
     
    Last edited: Aug 31, 2007
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes.

    No. This is not used by ISPconfig.

    Are there any copies of the file /etc/apache2/vhosts/Vhosts_ispconfig.conf with a date appended in the same directory?
     
  4. malder

    malder New Member

    This is all that is there:

    Code:
    [email protected]:/etc/apache2/vhosts$ ls -l
    total 16
    -rw-r--r-- 1 root root 6272 2007-08-31 13:42 Vhosts_ispconfig.conf
    -rw-r--r-- 1 root root 7215 2007-08-31 13:42 Vhosts_ispconfig.conf~
    
    Thanks for the response.
     
  5. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ifconfig
    , and what's in Vhosts_ispconfig.conf? Do the IP addresses match?
     
  6. malder

    malder New Member

    :eek:

    That's it. Good call. The new router changed from 192.168.0.* to 192.168.1.*. I changed the /etc/networking , but did not realize there was other settings that needed modding.

    Should I just go into the Vhosts_ispconfig.conf file manually and change it or is there a setting in ispconfig that should be changed.

    Thanks.
     
  7. malder

    malder New Member

    Sorry - should have looked first

    Management>server>settings>ipaddress - change to new IP
    Then had to make a change to each site to get Vhost file rewritten.

    Thanks for the support!
     

Share This Page