Changed ISP Address, Now Postfix SMTP Outbox Filling Up

Discussion in 'Installation/Configuration' started by AceFrahm, Mar 26, 2008.

  1. AceFrahm

    AceFrahm New Member

    My ISP changed my IP address,
    on a box with ISPconfig, Apache, PHP, Drupal, PROftp and Postfix.

    I changed the IP in many places according to instructions in other forum posts.
    Everything else works,

    BUT, now Outlook on my laptop can't send messages thru the SMTP on my server.

    Did I miss a setting?

    Telnet to port 25 on laptop to the server connects. . . .

    Why aren't the messages flowing?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which error messages do you get in the mail log?
     
  3. AceFrahm

    AceFrahm New Member

    From the Mail Log

    File
    /var/log/mail.log

    has repeated instances of this:

    Mar 27 05:29:12 dns01 postfix/tlsmgr[8202]: warning: request to update file /var/lib/postfix/prng_exch in non-postfix directory /var/lib/postfix
    Mar 27 05:29:12 dns01 postfix/tlsmgr[8202]: warning: redirecting the request to postfix-owned data_directory /var/lib/postfix
    Mar 27 05:29:12 dns01 postfix/tlsmgr[8202]: fatal: tls_prng_exch_open: cannot open PRNG exchange file /var/lib/postfix/prng_exch: Permission denied
    Mar 27 05:29:13 dns01 postfix/master[6198]: warning: process /usr/lib/postfix/tlsmgr pid 8202 exit status 1
    Mar 27 05:29:13 dns01 postfix/master[6198]: warning: /usr/lib/postfix/tlsmgr: bad command startup -- throttling
     
  4. AceFrahm

    AceFrahm New Member

    Is This Important?

    From file
    /var/log/messages

    Mar 27 04:52:19 dns01 syslogd 1.4.1#21ubuntu3: restart.
    Mar 27 05:22:05 dns01 -- MARK --
    Mar 27 05:26:12 dns01 kernel: [ 2678.568848] npviewer.bin[7990]: segfault at 00000000f77ca5cd rip 00000000f7aac0ed rsp 00000000fff29e00 error 7
    Mar 27 05:26:12 dns01 kernel: [ 2678.568853] npviewer.bin[8007]: segfault at 0000000073776f72 rip 00000000f783fba8 rsp 00000000f5b2dcbc error 4
    Mar 27 05:28:17 dns01 kernel: [ 2803.126594] npviewer.bin[8130]: segfault at 0000000000000002 rip 00000000f7af0e98 rsp 00000000ffe52cd0 error 4
    Mar 27 05:28:17 dns01 kernel: [ 2803.126746] npviewer.bin[8147]: segfault at 00000000e8f85d89 rip 00000000f7af0dd9 rsp 00000000f5ab7d30 error 4
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Which distribution are you using?
    What's in /etc/postfix/main.cf? What's the output of
    Code:
    netstat -tap
    ?

    Do you use a hostname or the new IP address in Outlook to connect? If you use a hostname, make sure that it already points to the new IP.
     
  6. AceFrahm

    AceFrahm New Member

    Status

    Distro is
    Ubuntu 7.10 Gutsy Gibbon

    Content of
    /etc/postfix/main.cf:
    Code:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    
    myhostname = dns01.acefrahm.com
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = dns01.acefrahm.com, localhost.acefrahm.com, , localhost, dns02.acefrahm.com
    relayhost = 
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain = 
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    
    virtual_maps = hash:/etc/postfix/virtusertable
    
    mydestination = /etc/postfix/local-host-names
    
    Output of
    netstat -tap

    Code:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name   
    tcp        0      0 *:mysql                 *:*                     LISTEN     5245/mysqld         
    tcp        0      0 *:www                   *:*                     LISTEN     6077/apache2        
    tcp        0      0 *:81                    *:*                     LISTEN     6038/ispconfig_http 
    tcp        0      0 *:ftp                   *:*                     LISTEN     6299/proftpd: (acce 
    tcp        0      0 dns02.acefrahm.c:domain *:*                     LISTEN     6220/named          
    tcp        0      0 dns01.acefrahm.c:domain *:*                     LISTEN     6220/named          
    tcp        0      0 localhost:domain        *:*                     LISTEN     6220/named          
    tcp        0      0 localhost:ipp           *:*                     LISTEN     5169/cupsd          
    tcp        0      0 localhost:953           *:*                     LISTEN     6220/named          
    tcp        0      0 *:smtp                  *:*                     LISTEN     6172/master         
    tcp        0      0 *:https                 *:*                     LISTEN     6077/apache2        
    tcp        1      0 dns01.acefrahm.com:smtp static-71-248-100-:1971 CLOSE_WAIT -                   
    tcp        0      0 dns01.acefrahm.com:smtp static-71-248-100-:1979 ESTABLISHED-                   
    tcp        1      0 dns01.acefrahm.com:smtp mail5.meetup.com:34070  CLOSE_WAIT -                   
    tcp        0      0 dns02.acefrahm.co:47636 a204-2-177-32.deplo:www TIME_WAIT  -                   
    tcp        0      0 dns02.acefrahm.co:34019 216.207.68.72:www       ESTABLISHED6614/firefox-bin    
    tcp        1      0 dns01.acefrahm.com:smtp static-71-248-100-:1955 CLOSE_WAIT -                   
    tcp        1      0 dns01.acefrahm.com:smtp static-71-248-100-:1948 CLOSE_WAIT -                   
    tcp        1      0 dns01.acefrahm.com:smtp static-71-248-100-:1963 CLOSE_WAIT -                   
    tcp6       0      0 *:imaps                 *:*                     LISTEN     5383/couriertcpd    
    tcp6       0      0 *:pop3s                 *:*                     LISTEN     5424/couriertcpd    
    tcp6       0      0 *:pop3                  *:*                     LISTEN     5399/couriertcpd    
    tcp6       0      0 *:imap2                 *:*                     LISTEN     5360/couriertcpd    
    tcp6       0      0 *:ssh                   *:*                     LISTEN     5120/sshd           
    tcp6       0      0 ip6-localhost:953       *:*                     LISTEN     6220/named          
    tcp6       0      0 *:smtp                  *:*                     LISTEN     6172/master 
     
  7. AceFrahm

    AceFrahm New Member

    Pictures of settings

    My ISPconfig DNS settings

    Outlook Setting

    It makes no difference whether or not I use the IP, or hostname dns01 or hostname "www".

    They all fail to send messages from outlook.
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Looks good. What's the output of
    Code:
    ls -la /var/lib/postfix
    ?
     
  9. AceFrahm

    AceFrahm New Member

    ls -la /var/lib/postfix

    Code:
    root@dns01:/# ls -la /var/lib/postfix
    total 12
    drwxr-xr-x  2 root root 4096 2007-10-31 17:11 .
    drwxr-xr-x 58 root root 4096 2008-03-28 07:45 ..
    -rw-------  1 root root 1024 2008-03-12 23:39 prng_exch
    Is this what a non-ISPConfig postfix would look like?
    what does prng_exch do?
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Try
    Code:
    chmod 644 /var/lib/postfix/prng_exch
    Does it work then?
     
  11. AceFrahm

    AceFrahm New Member

    Think I Found The Problem:Nvidia Driver

    My Outlook outbox magically started to work - I didn't need to chmod 644 as in your last suggestion.

    Yesterday, I decided to run the Synaptic update manager manually.
    It showed a dialog box that stated something previously failed to install properly,
    And that I needed to run some 'dpkg' command from the command line.

    I don't recall exactly what the command was,
    if I knew that it was the solution to this problem at the time,
    I would have recorded it.

    Then I ran a new "check for updates".

    Today, the Outlook outbox was empty.

    I believe what happened is this:
    the server halted (hung) during a previous software update,
    due to a buggy NVIDIA video card driver that doesn't like
    LINUX on a Dell 9200 with this particular card,
    at the very time when 'postfix' was somehow locked or halfway updated.

    Ever since I installed that video driver,
    the machine will hang every half-hour or so,
    but only when I log in and use the GUI. (Video memory leak? )
    When it hangs, it sounds like the hard drive starts thrashing.
    The mouse starts to stutter when it moves.
    Once it begins to stutter, I can't switch to any other windows,
    I can not even [CNTR - ALT - F1] to a console.
    Shortly after the mouse stutters, the mouse will stop responding completely.

    The only way to regain control is a hard reboot (power off!).

    This has led me to log out of the GUI every half hour if I can,
    to avoid the inevitable hang.

    Sometimes the driver hangs first, before I can log out.

    I believe that during a Synaptic software update, the postfix server got "stuck" or "locked"
    somehow at the same time the NVIDIA driver caused a hang.


    Sooo, by manually running that 'dpkg' command, postfix was put into a 'normal' state and Synaptic could run normally again.

    I only realized later, the next day, when the Outlook outbox on the laptop was empty, as if by magic, because none of my DELIBERATE attempts to force it to work succeeded. All of the steps I took were perfectly reasonable configurations.

    At first, I attributed the problem to the change in static IP address that occured at almost the same time
    as the failed software update,
    which was undetectable until the next (yesterday's) manual update.

    It seems what I REALLY need is a way to rip out the NVIDIA driver and go back to the default driver in a way that is not going to risk BLANKING my monitor if the rollback fails. (or perhaps upgrade to some video card driver that works.) I don't want to risk reinstalling my OS just because I can't see the screen if the next video driver change fails.

    I tried the NVIDIA drivers because I was sick of the 800x600 resolution I was getting by default. I wanted the NVIDIA driver so I could run at least 1027x768, if not more.

    The video card is a
    G72 [GeForce 7300 LE]
     

Share This Page