change website name

Discussion in 'General' started by aqua, Apr 8, 2007.

  1. aqua

    aqua New Member

    Hello, I wold like to change the website name in Mangement --> Server --> Settinging.

    What services will be affected, if any?

    Thanks
    Aqua
     
  2. Hans

    Hans Moderator ISPConfig Developer

    Hey,

    You can change the domainmname, but it must be the same as defined within your /etc/hosts file.

    You can set your hostname like this:

    echo hostname.yourdomain.com > /etc/hostname
    /bin/hostname -F /etc/hostname

    Verify the hostname with:

    hostname -f

    If the output of the hostname -f is:

    server1.yourdomain.com

    Your domainname within ISPConfig under Management > Server > Settings should be:

    Hostame: www
    Domain: yourdomain.com
     
  3. aqua

    aqua New Member

    thanks hans. I guess I should make my question a bit more specific.

    A little while ago I changed the name of a one of my clients websites in ISP manager --> Sites --> www.sitename.com

    All seemed to work ok (eg the new site name worked for apache), but email was being rejected.

    If, under the old site i had the user name bob, then his email was [email protected]. When I changed the domain name, I looked under the user tab, and ISPconfig changed everything to the newsite.com, ie. [email protected].

    Postfix was rejecting email to [email protected] though with message user not found, because apparently it still looked for [email protected].

    So, if I change my domain name in managment --> server --> settings, will i still be able to receive email? I noticed that incoming email is first checked to see if the user exists(eg [email protected]), then it delivers it using the domain name i specified in server --> settings ([email protected]).

    Thanks
    aqua
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No, this setting has nothing to do with postfix.

    Please make sure that you edit the co-domain from oldsite.com to newsite.com on the co-domain tab too and not just the main website domain.
     
  5. Wolfgang

    Wolfgang New Member

    Why would i set host=www and not host=server1 in Management > Server > Settings?
     
  6. falko

    falko Super Moderator ISPConfig Developer

    server1 would be correct. :)
     

Share This Page