Change the default website?

Discussion in 'Installation/Configuration' started by jboud, Mar 28, 2011.

  1. jboud

    jboud Member

    Hello there,
    I've been a successful ISPC3 owner for some months now, have solved most of my issues through reading the forums but I still have one issue that I'm not quite sure how to solve.

    Let's say a website traffic limit is reached and the website is getting deactivated. From that moment the default website that is shown when you try to access the deactivated website is the 1st one created or the 1st by alphabetical order, not sure which is correct but it happens that the 1st website created in the server is also the only one beginning with an "a". It probably has to do with the host system and not with the ISPC3 itself right? My OS is debian 5 lenny but I can't go around testing things as it's a live system and I wouldn't like my mailbox filled with wining customer messages. Has anyone solved this before?

    PS. any release date for the billing addon? :D can't wait to get my hands on that.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    If no website is specified in the apache configuration for a incoming request, apache delivers the content of the first website that it finds for the same IP address. Please see the section for default vhosts in the apache documentation on how to create a default website:

    Th billing module will get released soon. We are currently working on the implementation of the payment gateways. We will announce the release in the ispconfig blog when it is finished.
  3. jboud

    jboud Member

    Thanks for ultra fast response. :)
  4. jboud

    jboud Member

    Solved, giving some feedback:

    /etc/apache2/sites-enabled <--- all of your enabled sites

    Apache reads them alphabetically so there's your default vhost, the first alphabetical file.

    You want to change it? Sure no problemo, copy your wanabe default vhost file as 000-default.vhost (note there's a file named 000-default but it's missing the tail .vhost, so it's not being read by apache)

    cp /etc/apache2/sites-enabled/mywanabedefault.vhost /etc/apache2/sites-enabled/000-default.vhost

    /etc/init.d/apache2 restart

  5. 8omas

    8omas Member HowtoForge Supporter

Share This Page