change suhosin values - how?

Discussion in 'Server Operation' started by Ovidiu, Oct 25, 2010.

  1. Ovidiu

    Ovidiu Active Member

    running debian + ispcfg both latest as of now. installed accordingly to the perfect debian lenny server how-to
    getting an error in my logfiles:

    found this suhosin value: suhosin.request.max_value_length 65000 65000

    which seems to be the original. where exactly can I change it a) globally b) just for this one vhost?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    a) php.ini.
    b) in the php.ini field on the options tab of the website.
  3. Ovidiu

    Ovidiu Active Member

    got a problem with the method mentioned in b)

    entered this value:

    I entered that because I got this error: ALERT - configured GET variable value length limit exceeded - dropped variable 'urlref'

    It seems the default value is 512 so I doubled it.

    The result is that a certain page on that blog doesn't load anymore and I find this in

    this vhost's error log:

    syslog says:
    funny is that only page 3 isn't working and giving a segfault. all other pages of the above mentioned domain result in a 500 server error !?

    just realized it is not necessarily related as even after I took out those php.ini directives the segfault still occurs. Any ideas?

Share This Page