Change Postfix + Dovecot recipient_delimiter

Discussion in 'Installation/Configuration' started by msp1978, Aug 13, 2021.

  1. msp1978

    msp1978 New Member

    Hello,

    at first, i'm using howtoforge and ispconfig for years now on my private servers, its a great job you are all doing here.

    Yesterday i setup a new server to replace my old one. I used the howto
    The Perfect Server - Debian 10 (Buster) with Apache, BIND, Dovecot, PureFTPD and ISPConfig 3.2 (howtoforge.com)

    The server is running fine and working normally.

    After reading some new features in ispconfig i checked and enabled some more safety features like DKIM or SFP.
    I also found out that it is possible to use a delimiter "+" for my emails, this is a great feature i didn't knew until now.

    But now i aks if and where it is possible to change the recipient_delimiter from "+" to another one.
    In the /etc/postfix/main.cf i found the delimiter and changed it. But after that the emails are not delivered to the mailserver. It is only working for the "+" when i change it back.
    I found out / read that there is also the delimiter in dovecot, but all i found where disabled entries:

    I also didn't found this in the settings in ispconfig panel.
    All i know is that dovecot is only working with "+", but where can i change this.

    Also i read that dovecot should only be able to use 1 delimiter, not like postfix several ones. Is this still true or can dovecot use more delimiters in the actual version?
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Why is "+" not suitable delimiter for you?
     
  3. msp1978

    msp1978 New Member

    Hello,

    the "+" has the problem that some websites may reject this as username or spam bots can just filter this out.
    Also i want it to change it to a more user-friendly version, as an "-" is for most users a "better" thing to use.
    As this is only a private usage, i just want it to make it more "user-friendly" just for me :)

    But away from the reason why, the question remains the same: Where can we change the delimiter from "+" to whatever i like.
     
  4. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    You would change the postfix and dovecot config directly, eg. try
    Code:
    echo 'recipient_delimiter = -' >> /etc/dovecot/dovecot.conf
    echo 'recipient_delimiter = -' >> /usr/local/ispconfig/server/conf-custom/install/dovecot_custom.conf.master
    postconf -e 'recipient_delimiter = +-'
    systemctl reload dovecot
    postfix reload
    
     
    Th0m, ahrasis and msp1978 like this.
  5. msp1978

    msp1978 New Member

    Hello Jesse,
    thats it. I can now use the "-" as delimiter. Thank you a lot and keep up the great work!

    Michael
     

Share This Page