change password problem from ISPConfig 3

Discussion in 'Installation/Configuration' started by acumen, Jun 23, 2009.

  1. acumen

    acumen New Member

    I just make a clean install of Fedora11 and ISPConfig 3 from svn. Everything is fine and login as admin. Tried add/remove something also feel good! Then, I change the admin password and try to re-login. Problem comes out here! After changed, I cannot re-login with the new password. Then, I go to webmin to see how's the password changed. I found that there're difference with the encoded password if I create a user with password "123", and other user change the password to "123". So, I think that's the problem that I cannot login after cahnge. Seems the encrypt method in password change is not the one with login & create user page.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Were did you change the admin password? Under tools -> password? I just tested it with the svn release and it works fine.

    The code is the same.
  3. acumen

    acumen New Member

    dear till,

    yes, I change it from tool -> password. And I think here the only place to change password, right?

    I also feel strange that in the password page, after I changed, there's nothing to display that alert me change has been successful, it will return to the normal screen without any wording. Is it correct or it's the problem here? Thanks!
  4. Nicke

    Nicke New Member

    Do you have stuff like "&" in your password? I had the same problem.
    I changed my password first time i logged in and could not log in anymore.
    I had to connect with phpmyadmin and change the password. Used MD5 as encryption.
  5. acumen

    acumen New Member

    No, I haven't enter any "&" char inside the password. Here below is what I get from query browser,
    1. new create a user name "marco" with password "marco", the encrypted code is, "$1$HdqfgxyC$UNqOxCvH9QxffO8HQfGzm0"

    2. login with marco and change the password to "marco", actually is the same password and the encrypted code changed to, "$1$xi]FIYHx$1EOrqy9OxPdSlhefo8jTu1".

    :( no idea to the new generated password is.
  6. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    You have to keep in mind that it is a salted encryption of the password, so the encrypted password won't be the same even if the unencrypted is.
  7. bizkid64

    bizkid64 New Member

    Has anyone solved this yet?

    I'm having the same problem. I'm on my third try with this now. I've had ISPConfig 3 working just fine on another server, and everything worked fine. I've been tearing my hair out with this now for two days. Without changing anything else, I change the password through the tools option, and I'm immediately locked out.

    Please does anyone have any idea how to fix this?
  8. Nicke

    Nicke New Member

    Use phpmyadmin. Login as root.
    Select database "dbispconfig".
    Select table "sys_user".
    Edit user "admin".
    Select "MD5" in the drop down list for "passwort" and enter your wanted password.
    Run the query.


    Use a terminal.
    mysql -u root -p
    UPDATE dbispconfig.sys_user SET passwort = MD5('YOURPASSWORDHERE') WHERE sys_user.username='admin';
    You should now be able to log in as admin.
    Last edited: Jun 27, 2009
  9. garidan

    garidan New Member

    Latest version, fresh install (Powered by ISPConfig on Ubuntu 9.04 server 64bit and MySQL: 5.0.75-0ubuntu10.2).
    I have the same problem: changed password in tools-> change password and then I cannot login.
    I reset my password via SQL, but this is a bug.
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    I tested it several times now and it works fine for me. Does your password contain any special chars?
  11. garidan

    garidan New Member

    All small caps, no special char. I tried chrome as well as firefox 3.5. International settings: italian.
    It doesn't work for a new admin account as well. Something to do with php ? Do you use the md5 function of mysql to encode passwords ?
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    The passwords in ispconfig are encrypted with "crypt". MD5 is only a fallback solution. I will have to check the code, maybe I find something that can get wrong there. Please post it to the bugtracker so we can review it again.
  13. kronprom

    kronprom New Member

    i have same problem when i changed admin password in User Settings.
    Mysql DB sys_user passwordt was not encrypted with MD5.
    i have to manually change to MD5 in Mysql with

    UPDATE dbispconfig.sys_user SET passwort = MD5('yourpassword') WHERE sys_user.username='admin';
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats correct as ISPConfig uses crypt and not md5 for passwords. md5 is just a fallback solution to allow you to reset a password manually if nescessary.
  15. Festinalente

    Festinalente New Member

    locked out and can't get in

    Can anyone please help.

    I've stalled ISPconfig 3 latest version and it worked fine for about 4/5 days.
    Then just one day I tried to log in again and then the password didn't work anymore. Same for Mysql. It might have something to do that I've installed tomcat and moved ISP config to port 8090.

    Anyway, I've resetted the root password of Mysql and tried to reset the ISP password via mysql with
    UPDATE sys_user SET passwort = md5('admin') WHERE username = 'admin';

    But this doesn't work for me. When I try to log in I still get the message
    "error 1. Error username of password worng.1"

    Anybody any idee how I can get back in?

  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely the password that ispconfig uses to login to mysql is wrong. Please check if you are able to login to mysql with the username and password that you find in the file /usr/local/ispconfig/interface/lib/ If the login does not work, change the password in mysql so that it matches the password in that file (dont change it in the file as the password is used in several other files as well, so changing in mysql is easier).
  17. Festinalente

    Festinalente New Member

    Can loggin again

    Thxs, Indeed the mysql user was locked out. After resetting the password in mysql I could enter again ISP. I guess the lock out was caused because I restored an mysql dump of all tables from an other database.:)

Share This Page