Change order of tabs

Discussion in 'Developers' Forum' started by xaver, Oct 27, 2010.

  1. xaver

    xaver New Member


    i h*** it by updating an user, all tabs are in wrong order....
    In next bigger release i hope its a clean fix, but for next time a small and easy way

    @interface/web(admin/form/user.tform.php add by line ~ 97
    $modules_list2 = array ( 'dashboard' => 'dashboard','admin' => 'admin''client' => 'client''mail' => 'mail','sites' => 'sites''domain' => 'domain''dns' => 'dns''help' => 'help''monitor' => 'monitor''tools' => 'tools');
    $modules_list $modules_list2 $modules_list;

    1 row i get with var_export($modules_list) -> order it and second row is to merge the arrays with original list (if anybody has another tab)


    (i hope development is right and not tips and tricks)
    Last edited: Oct 28, 2010
  2. ivomendonca

    ivomendonca Banned

    Are this a pertinent question "tabs in wrong order" ?
    There is a right order for the tabs ?:confused:
  3. xaver

    xaver New Member

    sry i mean, after the normal setup you have a logical order

    Dashbaord for all infos
    System for all big settings and usergroups...
    Costumer for user and packages
    Monitor is logs.... Not so improtant if you use console often or antoher monitor solution
    Email is Costumer
    Webspace is Coustumer too
    DNS is often not so important -> not frist place of settings, not so often in use (maybe is interface von howtoforge for DNS in use)
    Domain -> Only if user cant setup a new Domain (since 3.0.3 you can unlock it)
    Help -> Support -> often antoher system in use
    Tools -> PW change and language, normal you dont change your pw every Day/Login

    -> If you go into Admin user in System and click save the original order is destroyed -> help is on tab2 .. (order by module name because ISPConfig scan all folders for modules.conf....)

    This is for 3.0.4 in bugtracker. This is a small trick/fix you dont want for customers and fpr you a changed menu.
    Last edited: Oct 28, 2010

Share This Page