Change ISPConfig's IP address

Discussion in 'HOWTO-Related Questions' started by riaanroux, May 15, 2012.

  1. riaanroux

    riaanroux New Member

    Hi there.
    Please could someone send me the steps to change ISPConfig 3.0.4.5 IP Address and still have all the services running 100%?

    I want to add domains and DNS Domains and email then just change the IP address sothat the server is online.

    Many thanks for the help.

    ISPConfig Rocks.

    Riaan
     
  2. riaanroux

    riaanroux New Member

    Is there anyone that can help me with this I really need to know if I can change the server's IP address after I have added domains on DNS?
     
  3. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's your distribution?
     
  4. riaanroux

    riaanroux New Member

    I have Ubuntu 10.04.4 LTS
     
  5. riaanroux

    riaanroux New Member

  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    These instructions are for ISPConfig 2!

    Change the IP in /etc/network/interfaces, adjust /etc/hosts, make sure all web sites in ISPConfig use the new IP and that your DNS records point to the new IP. That should do it.
     
  7. riaanroux

    riaanroux New Member

    Thank you, and this will update the DNS zones too or should I edit them manually one by one?
     
  8. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You must update the DNS zones manually.
     
  9. riaanroux

    riaanroux New Member

    Hi me again.

    Will it be better just to uninstall IPSConfig, change ubuntu's IP address and then reinstall ISPconfig will that not change the IP address where needed?

    Thanks
    Riaan
     
  10. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Not in the DNS zones.
     
  11. riaanroux

    riaanroux New Member

    that is okay will remove and add the domains on the DNS again but every thing else should be okay?
     

Share This Page