Change default PHP Version

Discussion in 'Installation/Configuration' started by Mario90, Feb 15, 2020.

  1. Mario90

    Mario90 Member

    Hello, i'm running latest version of ISPConfig on a Debian Stretch server (output of uname -a below)
    Linux ns3001667 4.9.0-12-amd64 #1 SMP Debian 4.9.210-1 (2020-01-20) x86_64 GNU/Linux
    My default PHP version is 7.4.2, i'm using Sury PHP repository to keep everything updated.
    [email protected]:/var/log/apache2# php --version
    PHP 7.4.2 (cli) (built: Feb 2 2020 07:56:32) ( NTS )
    Copyright (c) The PHP Group
    Zend Engine v3.4.0, Copyright (c) Zend Technologies
    with Zend OPcache v7.4.2, Copyright (c), by Zend Technologies
    I changed default PHP version via update-alternatives --config php and update-alternatives --config php-cgi by setting PHP 7.4 as my default version.

    However, all sites which have Default PHP version set are running an old version of php, which is:

    7.0.33-19+0~20200202.27+debian9~1.gbp5d283d

    How can i change the default php version of ISPConfig? Thanks.
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

Share This Page