change default email from squirrelmail to roundcube in Ubuntu

Discussion in 'ISPConfig 3 Priority Support' started by Victor Dugas, Oct 26, 2017.

  1. Victor Dugas

    Victor Dugas Member HowtoForge Supporter

    Hello, I can find instructions on how to do this in suse...but those instructions dont work under Ubuntu...nor do they resemble anything in my Ubuntu server. If anyone has any good instructions to do this, I have installed roundcube...but I cannot find where the symlinks go so that when someone types in www.example.com/webmail it shows roundcube and not squirrelmail. Thanks...
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    /webmail is not a symlinkt, its an Alias. You have to change the alias in the apache squirrelmail file from e.g. /webmail to /squirrelmail and then change the alias in the roundcube config file from /roundcube to /webmail and finally restart apache. The roundcube and apache config files should be either in /etc/apache2/conf-enabled/ folder or in /etc/apache2/conf.d/ folder.
     
  3. Victor Dugas

    Victor Dugas Member HowtoForge Supporter

    that is great, it was very easy to switch...only one question...is there a configuration that can be done to remove the "Server" textbox? I dont even know what the mail server is with ISPConfig...and it is a mail server that is intended for many to use...and will be using the same server inteljunky.com. Please view the image if you are unsure of what I mean...thanks again.
     

    Attached Files:

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Edit the roundcube config file and there set the server for smtp and imap to localhost. The file is in /etc/roundcube/ folder.
     
  5. Victor Dugas

    Victor Dugas Member HowtoForge Supporter

    would that be the following?

    $rcmail_config['smtp_server'] = '';

    $rcmail_config['mail_domain'] = '';
    in the main.inc.php? as this is the closest thing I can find in that folder to what you are recommending
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Set smtp_server and if you find a setting default_host, then set that as well to localhost, then check if the server field disappeared. if not, try to set mail_domain as well but I guess mail_domain might be soething different, so better try the other options fisrst.
     
  7. Victor Dugas

    Victor Dugas Member HowtoForge Supporter

    ok thank you. it all seems to be functioning properly, I only had one bounce, it was my wifes hotmail account...the rest of the testing emails went through (both ways) without issue.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

  9. Victor Dugas

    Victor Dugas Member HowtoForge Supporter

    hmm...I very much appreciate your assistance. I have filled out their form, what is there to lose...maybe they will have the answer I need. Maybe its as simple as someone could have had this IP before I did...and they were doing some nasty things with it...thanks again...
     
  10. Victor Dugas

    Victor Dugas Member HowtoForge Supporter

    Interesting Till...I have received a response from Microsoft indicating that my IP is currently on the spamhaus block list. I contacted spamhaus, and they said If I want to eliminate the chance that emails from my mail server will be bounced, that I should secure my smtp server with login information, username and password. That seems like a simple fix, however for me...I have no idea how to do that with the current setup...is there a chance that you would be interested in helping me do that? Then...yaay...I will be completely out of your hair because as far as I can tell, I know how to do pretty much everything else on my server.
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    All ISPConfig servers are secured with username and password by default, so nobody can send through your server without these login details. So I'm pretty sure your server is not an open relay as well, but you can test that easily:

    http://www.mailradar.com/openrelay/

    enter your IP address and wait for the result.

    My guess is that Spamhaus just gave you a standard response without even knowing how your system is setup or if your system is an open relay.
     
  12. Victor Dugas

    Victor Dugas Member HowtoForge Supporter

    wow your right...nice toolbox by the way, my results to the test was "All tested completed! No relays accepted by remote host!". I wonder how I can fix this...I mean...I hate spam...I would never inflict that on anyone else...and none of my clients even have access to send spam from my mail server nor would any of them know how...rofl...most of my hosting customers are some of the most computer illiterate people I have ever met...so as a result, my services have been all-inclusive...I basically do everything for them. So there is no possible way any spam even can be sent from my server.
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    How long do you have that IP address? Maybe the IP was used for spamming before. It takes months until a spammer IP gets cleared again.
     
  14. Victor Dugas

    Victor Dugas Member HowtoForge Supporter

    I have had this IP address for about one year...I have been hosting websites on it...but I had an older version of ISPConfig setup and email was not functioning...it is only in the last week...due to a new project that I require a fully functioning server that I went ahead and did a re-install...
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you had any problems that a website was hacked or malware was injected? It might be that you did not even notice it that spam was sent from your IP.

    Beside that, you can improve the reputation of your outgoing emails by enabling dkim for that mail domain and you should add an SPF record and the dkim key (when you enabled dkim) in the dns record of your domain.
     
  16. Victor Dugas

    Victor Dugas Member HowtoForge Supporter

    ok, as it is with my client base, I need to edit the pages on a constant basis...I have seen injected code...I know exactly what to look for...and have never seen anything of this nature in any documents hosted on my server...dkim and SPF...maybe I have heard of them, but thanks to my aging memory...I cannot confirm that :p
     
  17. Victor Dugas

    Victor Dugas Member HowtoForge Supporter

    ok...fun...i have keys...is there somewhere in ISPConfig to place them or would they belong in a file?
     
  18. Victor Dugas

    Victor Dugas Member HowtoForge Supporter

    ok i think i know how...ill report back later, thanks...
     
  19. Victor Dugas

    Victor Dugas Member HowtoForge Supporter

    ok...the entire DNS is signed...ill be able to test this some time tomorrow...thank you for all of your assistance...
     
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    You just enable dkim in the mail domain settings, then click on the generate key button and then click on save. ispconfig will store the keys automatically in the system and will start to sign the emails. No further steps required on the mail side. What you have to do to finish the dkim setup is that you add the dkim key to the dns zone on your dns server, this step has to be done on the authoritve dns server of your domain which is not nescessarily your ISPConfig server if you don't run your own dns server on ISPConfig.
     

Share This Page