CGI Form not working on site

Discussion in 'Installation/Configuration' started by pebkac, Jul 7, 2009.

  1. pebkac

    pebkac Member HowtoForge Supporter

    Hey all,

    Well I almost have all this working perfect. I just seen today that my form is not working. It says we dont have permission to access the file. Have a look for yourself.
    Just fill out a name and hit submit.

    You will get this:


    You don't have permission to access /cgibin/order.cgi on this server.

    I have CGI enabled on the site. I do have the php disabled and have tried it enabled and still nothing. Anyone, please help?
  2. Ben

    Ben ISPConfig Developer ISPConfig Developer

    well I get the followin error message, which is slightly different:

    For me it looks like the CGI is executed. The question is just if the file does really not exist or the access rights to that file are set properly.
  3. pebkac

    pebkac Member HowtoForge Supporter

    I know I fixed it by using webmin and making some changes there, but not sure if I should have done that...
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    First, never use webmin on a ispconfig server, the changes that you make with webmin will be removed automatically when you chenge something in the site in ispconfig. If you need some additional directives in a vhost you have to add them in the apache directives field of the website.
  5. pebkac

    pebkac Member HowtoForge Supporter

    thanks till, did not know. So if I reverse what I did in webmin, how can I get my cgi to work. Basically in Webmin , under Apache, and for that vhost I set the directories and documents to allow cgi.

    In ispconfig, I had the cgi box checked but kept getting an the forbidden access denied error???
  6. pebkac

    pebkac Member HowtoForge Supporter

    So how would I allow these cgi to work? You can look at this site, and enter a email address on the top and hit submit and you get

    ERROR 403 - Forbidden!
    The following error occurred:
    You are not permitted to access the requested URL.
    Please contact the webmaster with any queries.
    I have made sure that cgi is enabled. I just need to know what to do in ispconfig to make this work....
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Take a look at the error log of the website to find the reason for this error.
  8. pebkac

    pebkac Member HowtoForge Supporter


    I still cannot get this tow work. I'm not sure what log I should be looking at. Also, where do my cgi scripts go? Right now I have them in a folder in the root of my website called "cgibin" I notice outside of the root of my website there is a folder called "cgi-bin"?????

    I really need to get this work, I would greatly appreciate the help.

  9. till

    till Super Moderator Staff Member ISPConfig Developer

    error.log in the log directory of the website. Every website has just one log directory and there is just one error.log in it.

    the cgi-bin folder of the website.

    there is no such folder called cgibin in ISPConfig. The folder is called cgi-bin and it is outside the web folder.
  10. pebkac

    pebkac Member HowtoForge Supporter

    Here is the error log
    [Fri Jul 10 01:40:22 2009] [error] [client] client denied by server configuration: /var/www/
    [Fri Jul 10 01:40:26 2009] [error] [client] Options ExecCGI is off in this directory: /var/www/, referer:
    I know ispconfig does not have the cgi where I said. These sites used to be on a windows2000 server box and the cgi was in a folder called cgibin with the root of the website. So I need to move them to /var/www/, only thing is when I update my cgi scripts path will it see that directory or will it default to the root of the web??? I hope I make sense...this is new for me...thanks!!
  11. pebkac

    pebkac Member HowtoForge Supporter

    Ok, I moved all my cgi files to cgi=bin, and updated my html pages and my cgi scripts with the new path, now I get this?

    009] [error] [client] suexec policy violation: see suexec log for more details, referer:
    009] [error] [client] Premature end of script headers: index.cgi, referer:
    Any ideas??

Share This Page