cgi-bin + pearl

Discussion in 'Installation/Configuration' started by planet_fox, Mar 8, 2010.

  1. planet_fox

    planet_fox New Member

    hi

    I have a video system (ostube) and this have an upload script in pearl. When I upload a file on the installed system. The browser want download the upoad script.

    I the Root Order is a cgi-bin order, musst I copy the upload files to /var/www/webtube.de/cgi-bin ? for run this script or musst i some things installed for pearl.
     
  2. topdog

    topdog New Member HowtoForge Supporter

    That means the directory /var/www/webtube.de/cgi-bin is not script aliased, you need to set that up in your apache config
     
  3. planet_fox

    planet_fox New Member

    Why create the ispconfig3 system the order ? musst I change this in the Apache Directory by ispconfig website and option ?
     
  4. topdog

    topdog New Member HowtoForge Supporter

    Am not sure what happens with the ispconfig system if you edit the files by hand. So i guess someone who does can provide better feedback
     
  5. planet_fox

    planet_fox New Member

    see here the configuration in the vhost

    Code:
        # cgi enabled
            <Directory /var/clients/client1/web197/cgi-bin>
          Order allow,deny
          Allow from all
        </Directory>
        ScriptAlias  /cgi-bin/ /var/clients/client1/web197/cgi-bin/
        AddHandler cgi-script .cgi
        AddHandler cgi-script .pl
        # php as cgi enabled
        ScriptAlias /php5-cgi /var/www/php-cgi-scripts/web197/php-cgi-starter
        Action php5-cgi /php5-cgi
        AddHandler php5-cgi .php .php3 .php4 .php5
        <Directory /var/www/php-cgi-scripts/web197/>
            Order allow,deny
            Allow from all
        </Directory>
    
     
  6. topdog

    topdog New Member HowtoForge Supporter

    What is the extension of the script as both .pl and .cgi are enabled and should work.
     
  7. planet_fox

    planet_fox New Member

  8. topdog

    topdog New Member HowtoForge Supporter

    .pl should work have you set the executable bit on it using
    Code:
     chmod 755 script_name
    fuppes used to be good, but i have also switched to mediatomb now, the transcoding is so simple with mediatomb.
     
  9. planet_fox

    planet_fox New Member

    ok it run :)

    thanks for help
     
: cgi-bin, pearl

Share This Page