cgi-bin and htaccess problem

Discussion in 'Installation/Configuration' started by Camran, Oct 15, 2008.

  1. Camran

    Camran New Member

    I have installed script for upload center which have cgi based files there is 2 .htaccess file:

    one in /var/www/web1/cgi-bin/.htaccess
    Code:
    RewriteEngine on
    RewriteCond %{HTTP:Authorization} ^(.*)
    RewriteRule ^(.*) - [E=HTTP_CGI_AUTHORIZATION:%1]
    
    LimitRequestBody 10000000000000
    
    <IfModule mod_security.c>
           SecFilterEngine Off
           SecFilterScanPOST Off
           SetEnvIfNoCase Content-Type "^multipart/form-data;" MODSEC_NOPOSTBUFFERING=Do not buffer file uploads"
    </IfModule>
    <IfModule mod_gzip.c>
           mod_gzip_on No
    </IfModule>
    
    <IfModule mod_deflate.c>
           SetEnvIfNoCase Request_URI testenv.cgi no-gzip dont-vary
           SetEnvIfNoCase Request_URI upload_status.cgi no-gzip dont-vary
           SetEnvIfNoCase Request_URI upload.cgi no-gzip dont-vary
    
    one in /var/www/web1/web/.htaccess
    Code:
    deny from 127.1.1.4
    deny from 127.1.1.1
    RewriteEngine on
    
    RewriteRule    ^$                                               /cgi-bin/index.cgi [L]
    RewriteRule    ([0-9A-Za-z]{12})-del-([0-9A-Za-z]+)/.+$         /cgi-bin/index.cgi?del=$1-$2 [L]
    
    RewriteCond     %{REQUEST_FILENAME} !-f
    RewriteRule    ^([0-9A-Za-z\-_]*)/?([0-9A-Za-z]{12})(/[^\/]*|)(\.html?|$)$      /cgi-bin/index.cgi?op=download1&usr_login=$1&id=$2&fname=$3 [L]
    
    RewriteCond     %{REQUEST_FILENAME} !-f
    RewriteCond     %{REQUEST_FILENAME} !-d
    RewriteRule    ^([0-9A-Za-z\-_]+)(/[0-9a-z\-_]*/?|$)$           /cgi-bin/index.cgi?op=user_public&usr_login=$1&fld=$2 [L,NC]
    
    RewriteRule    ^latest-files(\d*).html$                         /cgi-bin/index.cgi?op=catalogue&page=$1 [L]
    
    RewriteCond     %{REQUEST_FILENAME} !-f
    RewriteRule    ^([a-z0-9\-\_]+).html(.*)                        /cgi-bin/index.cgi?op=page&tmpl=$1$2 [L]
    
    i got [FONT=Helvetica, Arial]403 Error- Forbidden!
    [/FONT]when opening site
    by the way i have written apache directives also
    Apache Directives
    (Optional):
    <Directory "/var/www/web1/web"> Options FollowSymLinks AllowOverride All </Directory>
    thanks for any help
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Are you trying to access a file from /var/www/web1/web or from /var/www/web1/cgi-bin?

    What are the outputs of
    Code:
    ls -la /var/www/web1/web
    and
    Code:
    ls -la /var/www/web1/cgi-bin
    ?

    Any errors in Apache's error log or the web site's error log?
     
  3. Camran

    Camran New Member


    Solved,

    adding

    Code:
    Options +FollowSymlinks
    Options +ExecCGI
    solved my all problems.

    Thanks
     

Share This Page