Certificate problem - solved

Discussion in 'ISPConfig 3 Priority Support' started by muekno, Oct 14, 2016.

  1. muekno

    muekno Member HowtoForge Supporter

    As I mentioned earlier, when I did the update from ISPConfig 3.0.x to 3.1 I said "no" to recreate certificates, but calling ISPConfig with https my browser said my certificates are invalid. Before I had official cerificate from STARTSSL.

    After all other things are fixed now and are running well, I checked that problem an found out that in /etc/apache2/sites-available/ispconfig.vhost my SSL Settings (path to my files) are replaced with the default
    "# SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
    # SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key
    #SSLCACertificateFile /usr/local/ispconfig/interface/ssl/ispserver.bundle"

    Restoring my files (pathes) https works fine again, maybe there is a still a bug?
    I had that problem on both my test system and my production system.

    Also Apache status tells me since quit a time the # NameVirtualHost statement is depreciate, I comment ist out and all is OK. May be in further ISPConfig Versions the statement should be left out when creating apache config files

    Have a nice day and weekend

    etruel likes this.

Share This Page