CentOS4.4 ISPConfig installation buggy...

Discussion in 'Installation/Configuration' started by Heinz09, May 10, 2007.

  1. Heinz09

    Heinz09 New Member

    I installed CentOS4.4 according to the step by step tutorial, everything went kinda perfect.
    Until I wanted to install ISPConfig... Here is the final message I got with the installation.

    Code:
    All prerequisites are fulfilled.
    Here we go...
    
    Warning: include(config.inc.php): failed to open stream: No such file or directory in /root/Desktop/install_ispconfig/install.php on line 665
    
    Warning: include(): Failed opening 'config.inc.php' for inclusion (include_path='.:') in /root/Desktop/install_ispconfig/install.php on line 665
    
    Warning: mysql_connect(): Access denied for user 'root'@'localhost' (using password: NO) in /root/Desktop/install_ispconfig/install.php on line 685
    Could not connect to db
    Restarting some services...
    ./setup2: line 1117: [: ==: unary operator expected
    ./setup2: line 1135: /etc/rc.d/init.d/ispconfig_server: No such file or directory
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
    
    From there I tried to get it running, and it kinda worked, until I try to actually run it.
    Now for some reason this pops up

    Code:
     /etc/rc.d/init.d/ispconfig_server start
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Starting ISPConfig system...
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    fopen: No such file or directory
    ispconfig_httpd: could not open document config file /root/ispconfig/httpd/conf/httpd.conf
    /root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
    
    Warning: include(/home/admispconfig/ispconfig/lib/config.inc.php): failed to open stream: No such file or directory in /root/ispconfig/scripts/lib/config.inc.php on line 30
    
    Warning: include(): Failed opening '/home/admispconfig/ispconfig/lib/config.inc.php' for inclusion (include_path='.:') in /root/ispconfig/scripts/lib/config.inc.php on line 30
    Could not connect to MySQL server!FreshClam is already running!
    ISPConfig system is now up and running!
    
    :confused: Please I am as lost as can be, can anyone help?
     
  2. Heinz09

    Heinz09 New Member

    Code:
    /etc/rc.d/init.d/ispconfig_server start
    
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    /etc/rc.d/init.d/ispconfig_server: line 39: 20544 Segmentation fault      /root/ ispconfig/php/php -q /root/ispconfig/scripts/shell/firewall.php
    ISPConfig system is now up and running!
    
    Once again after messing around this is what it's doing now.... getting warmer?
     
  3. till

    till Super Moderator

    Now, because ISPConfig is not installed completely on your server. We had to fix your first problem and then reinstall ISPConfig.

    1) Uninstall ISPConfig be running:

    rm -rf /root/ispconfig
    rm -rf /home/admispconfig

    2) Delete the complete ISPConfig mysql database.

    3)
    Installation:

    - Download it to e.f. /tmp and unpack it. Do not try to install it from /root/ispconfig or /home/admispconfig
    - make sure that you have enough space on your harddisk, you need approx 250 MB in the /root directory during installation
    - Make sure that there exists nor mysl database with the same name that you choose for the ispconfig database in the installer.
    - Make sure that your mysql user has root permissions ( to enable the installer to create the mysql database during setup)
    - enter theinstall_ispconfig directory with the cd command before you execute the setup script.
     
  4. Heinz09

    Heinz09 New Member

    now again...

    Well for some reason now when it asks for the host name and domain it keeps telling me that the URL is not reachable.

    I can ping it, I can see it, but ISPconfig just ignores it :(
     
  5. Heinz09

    Heinz09 New Member

    :) Happy :)

    It works after a bit more messing around, lots of thanks :)
     

Share This Page