CentOS VM Image Corruption

Discussion in 'Installation/Configuration' started by yaw, Oct 9, 2011.

  1. yaw

    yaw New Member

    Hi,

    I've downloaded both the CentOS 5.7 x64 ISPConfig 3 and CentOS 6.0 x64 ISPConfig 2 VM images, and both zip files seem corrupt. I've tried 3 separate downloads on 2 separate machines.

    The Debian zip files seem okay.

    Help?

    Thanks.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Both files are working for me. What error message do you get? Did you get any errors during download?
     
  3. yaw

    yaw New Member

    No errors on the download. I can't open the zip file. Winzip says that it's an invalid zip archive. It's odd. I wonder if it has something to do with the 1GB file size. It's almost as if it gets to 1GB, and then the download completes. Maybe comcast is mucking with the data stream.

    Any other way to download them? FTP? Mirrors?

    Thanks.
     
  4. yaw

    yaw New Member

    Well, I tried to download using my work PC as well as a 3rd ISP. This doesn't appear to be a comcast issue.

    The download completes to 1.00GB on the button. The image is actually 1.02GB, but it only downloads 1.00GB. Again, there are no errors and everything appears to have completed successfully.
     
  5. madsage

    madsage New Member

    i also had the same problem with CentOS 5.7 x64 ISPConfig 3 image.

    seems to finish download at 1.00gb when infact listed file size is 1.02gb.

    winrar reports; ! C:\Downloads\The_Perfect_Server_-_CentOS_5.7_x86_64__ISPConfig_3___x86_64_.zip: Unexpected end of archive



    madsage
     
  6. falko

    falko Super Moderator ISPConfig Developer

  7. yaw

    yaw New Member

    I've tried winzip, and it's the same issue.
     
  8. madsage

    madsage New Member

    yep i tried winzip too for kicks, And what piece of adware that has become. lol

    madsage
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    We will upload a new archive of the vm image to see if that fixes the problem.
     
  10. falko

    falko Super Moderator ISPConfig Developer

    I've just found the problem and corrected it. The uploaded image was not corrupt, the problem was that the file is bigger than 1GB which needed a special setting in our nginx configuration (proxy_max_temp_file_size).

    I'd like to apologize for the inconvenience.
     
  11. madsage

    madsage New Member

    sweet. thanks Falko
     

Share This Page