centos update php 5.2 to 5.3

Discussion in 'General' started by florix.net, Apr 27, 2017.

  1. florix.net

    florix.net Member

    Hi,

    I have centos server with latest ispconfig 3.
    my php version is as follows
    [[email protected] ~]# php -v
    PHP 5.2.10 (cli) (built: Nov 13 2009 11:24:03)
    Copyright (c) 1997-2009 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies

    how can I update to php 5.3 or higher?
     
  2. Lionheart82

    Lionheart82 Member

    Probably your system has Centos 5 witch is now at the EOL and you need to move into a new OS.
    Even tough it you search for other repos you will find higher php versions that 5.2.
     
  3. ahrasis

    ahrasis Active Member

    Upgrading distro is a good idea especially when php is now version 7.1 and php7 is very much faster and more reliable. You may compile lower version of php and make them as options, if you need them for any of your older website(s).
     

Share This Page