CentOS Postfix+Courier problem

Discussion in 'HOWTO-Related Questions' started by zeroday, Dec 22, 2007.

  1. zeroday

    zeroday New Member

    I installed everything according to this guide:
    http://www.howtoforge.com/virtual-users-and-domains-postfix-courier-mysql-centos5.1

    but when I try to login using thunderbird, I get a login failed error. My maillog shows a successful login:

    Code:
    Dec 22 11:58:13 imapd: Connection, ip=[::ffff:xxxx]
    Dec 22 11:58:15 authdaemond: received auth request, service=imap, authtype=login
    Dec 22 11:58:15authdaemond: authmysql: trying this module
    Dec 22 11:58:15  authdaemond: SQL query: SELECT email, password, "", 5000, 5000, "/home/vmail", CONCAT(SUBSTRING_INDEX(email,'@',-1),'/',SUBSTRING_INDEX(email,'@',1),'/'), quota, "", "" FROM users WHERE email = "[email protected]"
    Dec 22 11:58:15 authdaemond: password matches successfully
    Dec 22 11:58:15 authdaemond: authmysql: sysusername=<null>, sysuserid=5000, sysgroupid=5000, homedir=/home/vmail, [email protected], fullname=<null>, maildir=domain.com/username, quota=10485760, options=<null>
    Dec 22 11:58:15 authdaemond: Authenticated: sysusername=<null>, sysuserid=5000, sysgroupid=5000, homedir=/home/vmail, [email protected], fullname=<null>, maildir=domain.com/username, quota=10485760, options=<null>
    
    The SQL query looks a bit dodgy, it produces empty columns when I ran it manually using phpmyadmin. I'm not sure what the problem is :s
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    uname -a
    ? Does your Courier configuration (the formatting) look like the one in the tutorial? Courier is very finicky about this (newlines, etc.).
     
  3. zeroday

    zeroday New Member

    I double checked though all the files. This is the output of uname -a
    Linux lixx-xxx 2.6.23.1-linodexx #1 Sun Nov 4 12:03:06 EST 2007 i686 i686 i386 GNU/Linux

    (xx are numbers).

    Edit: one other thing I didn't understand from the guide is "Our hostname in this example is server1.example.com, and it has the IP address 192.168.0.100, so we change /etc/hosts as follows:"
    My server ip is a 69.xx..... one, what should I put in the hosts file?
     
    Last edited: Dec 23, 2007
  4. zeroday

    zeroday New Member

    Edit: I got the telnet working after doing yum install cyrus-sasl-plain. I have to still check on thunderbird.

    ----- old message -----
    Ok, I uninstalled it all and started again. This time I'm sure I got the hostname part right, this is my /etc/hosts:

    Code:
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1               localhost.localdomain localhost
    69.xx.xx.xx lixx-xxx.members.linode.com lixx-xxx
    ::1             localhost6.localdomain6 localhost6
    
    But now when I telnet to localhost port 25, it opens and closes the connection:

    Code:
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    Connection closed by foreign host.
    
    I found these in some of the logs (not maillog):
    Code:
    Dec 23 23:35:35 lixx-xxx postfix/smtpd[12058]: warning: xsasl_cyrus_server_get_mechanism_list: no applicable SASL mechanisms
    Dec 23 23:35:35 lixx-xxx postfix/smtpd[12058]: fatal: no SASL authentication mechanisms
    Dec 23 23:35:36 lixx-xxx postfix/master[12051]: warning: process /usr/libexec/postfix/smtpd pid 12058 exit status 1
    Dec 23 23:35:36 lixx-xxx postfix/master[12051]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
    Dec 23 23:38:13 lixx-xxx postfix/smtpd[12072]: warning: xsasl_cyrus_server_get_mechanism_list: no applicable SASL mechanisms
    Dec 23 23:38:13 lixx-xxx postfix/smtpd[12072]: fatal: no SASL authentication mechanisms
    Dec 23 23:38:14 lixx-xxx postfix/master[12051]: warning: process /usr/libexec/postfix/smtpd pid 12072 exit status 1
    Dec 23 23:38:14 lixx-xxx postfix/master[12051]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
    Dec 23 23:43:37 lixx-xxx postfix/smtpd[12126]: warning: xsasl_cyrus_server_get_mechanism_list: no applicable SASL mechanisms
    Dec 23 23:43:37 lixx-xxx postfix/smtpd[12126]: fatal: no SASL authentication mechanisms
    Dec 23 23:43:38 lixx-xxx postfix/master[12051]: warning: process /usr/libexec/postfix/smtpd pid 12126 exit status 1
    Dec 23 23:43:38 lixx-xxx postfix/master[12051]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
    
    postfix check doesn't show any errors or anything.
     
    Last edited: Dec 24, 2007
  5. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/postfix/main.cf?
     
  6. zeroday

    zeroday New Member

    I don't know how, but its finally working lol. Strange thing is it wasn't working in the morning when I tried it, but finally worked now. :D
     

Share This Page