CentOS Mail Server with Virtual Domains Howto

Discussion in 'Server Operation' started by morenz, Mar 21, 2007.

  1. morenz

    morenz New Member

    Hi folks!
    I'm new to the forum. It's my first message, 'cause I made a lot of browse in these months...

    So, what's my problem?
    I'm following the "Virtual Users With Postfix, PostfixAdmin, Courier, Mailscanner, ClamAV On CentOS" howto to set up a mail server.
    I just finished to build up a 3-domain mail server with aliasing without database (it's just a small business...), but I realized that I needed DB support 'cause I ran into duplicate users (i.e. [email protected], [email protected], etc.) and the sole /etc/aliases file could not make me manage this issue.

    I executed all steps, but when I try to run
    sudo rpmbuild -ta courier-authlib-0.58.tar.bz2
    I get the following response (I will translate, my system is in Italian):
    dependencies compilation failed:
    gcc-c++ needs courier-authlib-0.58-1.i386

    OK, I said, I found that rpm and --as root-- installed it (rpm -ivh courier-authlib-0.58-1.i386.rpm)
    then I ran again
    sudo rpmbuild -ta courier-authlib-0.58.tar.bz2
    the system response was the same.

    What can it be?
    Thanks in advance and maaaaaaaaaaaany congratulations for the site...
    Morenz
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Is gcc-c++ installled? Please run
    Code:
    yum install gcc-c++
     
  3. morenz

    morenz New Member

    You got it....
    I was sure I had already installed it, but I was wrong...
    Now i'm goin' on, hoping not to have other "breaks"...

    Thanks!
    Morenz
     

Share This Page