CentOS ISPConfig3 on AWS with Roundcube..

Discussion in 'ISPConfig 3 Priority Support' started by Vinay Samant, Dec 23, 2018.

  1. Vinay Samant

    Vinay Samant New Member

    hii..

    i have above configuration. earlier incoming mails were not coming. so i removed dovecot & postfix and reinstalled.
    now it shows "Connection to storage server failed." on Roundcube Login.
    The login is at https://marathi.gov.in/webmail/
    my "dovecot -n" is
    [[email protected] conf.d]# dovecot -n
    # 2.2.36 (1f10bfa63): /etc/dovecot/dovecot.conf
    # OS: Linux 3.10.0-862.14.4.el7.x86_64 x86_64 CentOS Linux release 7.6.1810 (Core)
    # Hostname: ns01.santwani.in
    auth_mechanisms = plain login
    first_valid_uid = 1000
    mbox_write_locks = fcntl
    namespace inbox {
    inbox = yes
    location =
    mailbox Drafts {
    special_use = \Drafts
    }
    mailbox Junk {
    special_use = \Junk
    }
    mailbox Sent {
    special_use = \Sent
    }
    mailbox "Sent Messages" {
    special_use = \Sent
    }
    mailbox Trash {
    special_use = \Trash
    }
    prefix =
    }
    passdb {
    driver = pam
    }
    ssl = required
    ssl_cert = </etc/pki/dovecot/certs/dovecot.pem
    ssl_key = # hidden, use -P to show it
    userdb {
    driver = passwd
    }
    and i get these errors in my mail-log..
    Dec 23 06:31:33 ns01 clamd[8804]: SelfCheck: Database status OK.
    Dec 23 06:32:48 ns01 dovecot: imap-login: Disconnected (tried to use disallowed plaintext auth): user=<[email protected]>, rip=13.232.56.64, lip=172.21.0.13, session=<Fzkfpqp9nO0N6DhA>
    Dec 23 06:33:31 ns01 dovecot: imap-login: Disconnected (tried to use disallowed plaintext auth): user=<[email protected]>, rip=13.232.56.64, lip=172.21.0.13, session=<hNSyqKp9Du4N6DhA>
    Dec 23 06:34:43 ns01 dovecot: imap-login: Disconnected (tried to use disallowed plaintext auth): user=<[email protected]>, rip=13.232.56.64, lip=172.21.0.13, session=<aq7+rKp9hIAN6DhA>
    Dec 23 06:35:01 ns01 dovecot: imap-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<Si4Mrqp9Cp4AAAAAAAAAAAAAAAAAAAAB>
    Dec 23 06:35:01 ns01 dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<YzIMrqp9ztkAAAAAAAAAAAAAAAAAAAAB>
    Dec 23 06:35:01 ns01 postfix/smtpd[16931]: connect from localhost[::1]
    Dec 23 06:35:01 ns01 postfix/smtpd[16931]: lost connection after CONNECT from localhost[::1]

    kindly advice..

    i have purchased monthly subscription for priority support. I am just wondering if you have kind of service where some expert from your panel can actually access my server and configure it better and secure, professionally, with additional charges, i will be highly obliged.. kindly let me know..
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. Vinay Samant

    Vinay Samant New Member

    hi..
    i reconfigured services as explained in release note -
    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3.1.tar.gz
    tar xvfz ISPConfig-3.1.tar.gz
    cd ispconfig3_install/install
    php -q update.php

    i had follwing message -
    no crontab for getmail
    Restarting services ...
    Job for amavisd.service failed because the control process exited with error code. See "systemctl status amavisd.service" and "journalctl -xe" for details.

    and problem stays!
    roundcube still says "Connection to storage server failed."
     
  4. Vinay Samant

    Vinay Samant New Member

    ohhh sorry ...
    just read the mail-error log.. it says
    "Dec 23 17:13:48 ns01 dovecot: auth: Fatal: Unknown database driver 'mysql'"
    so did "yum -y install dovecot-mysql" ... i read about it somewhere ..
    and restarted dovecot.. and i can login now..

    but when i try to send message, it gets stuck in Q..

    -Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
    AD7A31EC005E5 171708 Sun Dec 23 17:24:29 [email protected]
    (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    [email protected]

    -- 167 Kbytes in 1 Request.

    Also for incoming mail
    Dec 23 17:29:28 ns01 postfix/smtpd[15775]: connect from mail-lj1-f180.google.com[209.85.208.180]
    Dec 23 17:29:30 ns01 postfix/smtpd[15775]: NOQUEUE: filter: RCPT from mail-lj1-f180.google.com[209.85.208.180]: <[email protected]>: Sender address triggers FILTER amavis:[127.0.0.1]:10026; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<mail-lj1-f180.google.com>
    Dec 23 17:29:30 ns01 postfix/smtpd[15775]: NOQUEUE: filter: RCPT from mail-lj1-f180.google.com[209.85.208.180]: <[email protected]>: Sender address triggers FILTER amavis:[127.0.0.1]:10024; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<mail-lj1-f180.google.com>
    Dec 23 17:29:30 ns01 postfix/smtpd[15775]: 3E97B1EC005E7: client=mail-lj1-f180.google.com[209.85.208.180]
    Dec 23 17:29:30 ns01 postfix/cleanup[15790]: 3E97B1EC005E7: message-id=<[email protected]om>
    Dec 23 17:29:30 ns01 postfix/qmgr[32010]: 3E97B1EC005E7: from=<[email protected]>, size=7589, nrcpt=1 (queue active)
    Dec 23 17:29:30 ns01 postfix/smtp[15791]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
    Dec 23 17:29:30 ns01 postfix/smtp[15791]: 3E97B1EC005E7: to=<[email protected]>, relay=none, delay=0.57, delays=0.56/0.01/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Dec 23 17:29:31 ns01 postfix/smtpd[15775]: disconnect from mail-lj1-f180.google.com[209.85.208.180]
    Dec 23 17:29:31 ns01 dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=13.232.56.64, lip=172.21.0.13, mpid=15797, session=<RoO80rN9auEN6DhA>
    Dec 23 17:29:31 ns01 dovecot: imap([email protected]): Logged out in=50 out=519

    what have i configured wrongly now??
     
  5. Vinay Samant

    Vinay Samant New Member

    whole issue is around :
    Job for amavisd.service failed because the control process exited with error code. See "systemctl status amavisd.service" and "journalctl -xe" for details.
    i am not able to get this started somehow..
    Redirecting to /bin/systemctl status amavisd.service

    ‚óŹ amavisd.service - Amavisd-new is an interface between MTA and content checkers.
    Loaded: loaded (/usr/lib/systemd/system/amavisd.service; enabled; vendor preset: disabled)
    Active: failed (Result: start-limit) since Sun 2018-12-23 17:46:08 UTC; 9min ago
    Docs: http://www.ijs.si/software/amavisd/#doc
    Process: 31777 ExecStart=/usr/sbin/amavisd -c /etc/amavisd/amavisd.conf (code=exited, status=13)
    Main PID: 27348 (code=exited, status=0/SUCCESS)

    Dec 23 17:46:08 ns01.santwani.in systemd[1]: Failed to start Amavisd-new is an interface between MTA and content checkers..
    Dec 23 17:46:08 ns01.santwani.in systemd[1]: Unit amavisd.service entered failed state.
    Dec 23 17:46:08 ns01.santwani.in systemd[1]: amavisd.service failed.
    Dec 23 17:46:08 ns01.santwani.in systemd[1]: amavisd.service holdoff time over, scheduling restart.
    Dec 23 17:46:08 ns01.santwani.in systemd[1]: Stopped Amavisd-new is an interface between MTA and content checkers..
    Dec 23 17:46:08 ns01.santwani.in systemd[1]: start request repeated too quickly for amavisd.service
    Dec 23 17:46:08 ns01.santwani.in systemd[1]: Failed to start Amavisd-new is an interface between MTA and content checkers..
    Dec 23 17:46:08 ns01.santwani.in systemd[1]: Unit amavisd.service entered failed state.
    Dec 23 17:46:08 ns01.santwani.in systemd[1]: amavisd.service failed.
     
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Test first logging in to Roundcube and send mail to yourself. Does this mail arrive?
    If that works, what kinds of mails are not arriving?
    When posting logs and text files, please use code tags to keep it more readable.
     
  7. Vinay Samant

    Vinay Samant New Member

    Dear Teleman,
    thanks a lot for reading all my junk there and having patience with me.
    Now things are working.
    i deleted amavis & freshclam and everything related, several times and reinstalled. then reconfigured isp as you guided. but no luck. everytime it will give me same error and amavisd will fail. only once, something happened and i managed to receive 2mails in q.. but that give me confidence and some light of hope.

    now finally at 2AM in india, i decided to give final attempt to it. I removed everything. this time to my extreme badluck i accidentally removed mysql as well. then recovered it. and reinstalled all amavisd and freshclam related things. Recreated services and "decided not reconfigure ISP". So i just restarted all services and flushed mailq and guess what... everything just started working. i can send-receive mails now!
    thank you very much for helping me out.

    *i maybe/surely wrong, but is it possible that somehow "php -q update.php" does something that mess around with running amavisd and then it cant start it again? what i learned is, if i un/reinstall postfix and/or dovecot then i should reconfigure ispconfig.. not otherwise. correct me if i m wrong..

    and good night bye!
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    ispconfig configures postfix and amavis and dovecot, these services will not work otherwise. When you reinstall them, then you must run ispconfig update.php afterward with reconfigure services = yes to fix the setup.
     
  9. Vinay Samant

    Vinay Samant New Member

    i did it several times yesterday, "php -q update.php" and everytime amavisd crashed. finally in last attempt i didn't do that. and server is fine till now.
     
  10. Vinay Samant

    Vinay Samant New Member

    hii..

    i tried creating a new SSL and somehow LE was not working. The SSL was not getting attached to newly created domain. Tried many ways as per documentation and support forum, but no luck. So finally i decided to upgrade the entire ISPConfig using "ispconfig_update.sh". As per my expectation everything stopped after -
    Configuring Postfix
    Configuring Dovecot
    Configuring Spamassassin
    Configuring Amavisd
    i knew there is something wrong with my "Amavisd" as stated.
    I need professional assistance. I also requested quote for remote login and assistance. But havn't got any reply. Please help me out, professionally, i am willing to pay for it. If any of your experts can have a look at this server config once, i am sure all services will go through. I have just 5 sites running currently, but this email, amavisd and LE are important aspects.. please help..
     
  11. Vinay Samant

    Vinay Samant New Member

    i dont know, somehow my server is back online and things working..
    But i still need some expert to look into it please.. kindly help..
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

Share This Page