CentOS Installation Issues (and my fixes)

Discussion in 'Installation/Configuration' started by wyattbiker, Nov 6, 2011.

  1. wyattbiker

    wyattbiker New Member

    My platform is Mac OS X Lion Server, running VMWare.
    Following the document http://www.howtoforge.com/perfect-server-centos-6.0-x86_64-ispconfig-3
    I found the following issues during install:
    ================================================================

    5 Configure The Firewall
    --------------------------
    system-config-firewall not available on CentOS.

    Fixed by: yum install system-config-firewall


    7 Enable Additional Repositories And Install Some Software
    ------------------------------------------------------------
    First we import the GPG keys for software packages:

    This Step gave me errors
    ---------------------------------------------
    rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY*
    error: /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6: key 1 import failed.
    error: /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-Debug-6: key 1 import failed.
    error: /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-Security-6: key 1 import failed.
    error: /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-Testing-6: key 1 import failed.

    But if you do this and see the keys everything is ok.
    [[email protected] ~]# rpm -qa --qf '%{N}-%{V}-%{R}\t%{summary}\n' gpg-pubkey
    gpg-pubkey-c105b9de-4e0fd3a3 gpg(CentOS-6 Key (CentOS 6 Official Signing Key) <[email protected]>)
    gpg-pubkey-d0ff3d16-4e0fd442 gpg(CentOS-6 Debuginfo Key (CentOS-6 Debuginfo Signing Key) <[email protected]>)
    gpg-pubkey-ef1d6db8-4e0fd7f0 gpg(CentOS-6 Testing Key (CentOS-6 Test and Beta Signing Key) <[email protected]>)
    gpg-pubkey-fe837f6f-4e0fd77e gpg(CentOS-6 Security Key (CentOS-6 Official Security Key) <[email protected]>)


    This step also make sure enabled=1 (mine was 0)
    ---------------------------------------------------
    Edit /etc/yum.repos.d/epel.repo...

    vi /etc/yum.repos.d/epel.repo

    ... and add the line priority=10 to the [epel] section:

    [epel]
    name=Extra Packages for Enterprise Linux 6 - $basearch
    #baseurl=http://download.fedoraproject.org/pub/epel/6/$basearch
    mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-6&arch=$basearch
    failovermethod=priority
    enabled=1
    priority=10
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
    [...]

    8 Quota
    ========

    This step gave me the following messages. I assume it's ok?

    # quotacheck -avugm
    quotacheck: Scanning /dev/mapper/vg_centsrv-lv_root [/] done
    quotacheck: Cannot stat old user quota file: No such file or directory
    quotacheck: Cannot stat old group quota file: No such file or directory
    quotacheck: Cannot stat old user quota file: No such file or directory
    quotacheck: Cannot stat old group quota file: No such file or directory
    quotacheck: Checked 5167 directories and 38586 files
    quotacheck: Old file not found.
    quotacheck: Old file not found.


    10 Install Courier-IMAP, Courier-Authlib, And Maildrop
    ========================================================
    This step fails so use yum install, but you need to be root. So exit the su user. After you yum install the 2 packages,
    su user and go back to downloads

    @centsrv downloads]$ sudo rpmbuild -ta courier-authlib-0.63.0.tar.bz2
    error: Failed build dependencies:
    gcc-c++ is needed by courier-authlib-0.63.0-1.el6.x86_64
    redhat-rpm-config is needed by courier-authlib-0.63.0-1.el6.x86_64



    14 Install Amavisd-new, SpamAssassin And ClamAV
    =================================================
    This step gives an error. I did not install amavisd

    yum install amavisd-new spamassassin clamav clamd unzip bzip2 unrar perl-DBD-mysql
    Error: Package: amavisd-new-2.6.4-2.el6.noarch (epel)
    Requires: /etc/clamd.d
    Available: clamd-0.97.2-5.el6.x86_64 (epel)
    Not found
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest

    15 Installing Apache2 With mod_php, mod_fcgi/PHP5, And suPHP
    ============================================================
    The php-mssql install part fails. I did not install it.
     

Share This Page