CentOS - Hyper-V - No network adapter

Discussion in 'Installation/Configuration' started by brentw, Aug 26, 2009.

  1. brentw

    brentw New Member


    I was following along the instructions found in the above tutorial installing the Hyper-V Linux Integration Components. I run into a problem with the following line because I don't have a network adapter in this virgin CentOS 5 x64 guest VM.

    yum groupinstall "Development Tools"

    Where can I download this as an ISO and how would install it? Or is there a way for me to add an network adapter in Hyper-V and continue on with the tutorial?

    Thanks for your time.
  2. brentw

    brentw New Member

    problem solved

    I had the wrong type of network adapter selected for the guest VM. I was sure I had selected the Legacy Adapter when I created the VM but when I double checked it was not. Changed it to legacy adapter and it work fine.
  3. digg1980

    digg1980 New Member

    Another detailed how to Linux on Hyper-V


    We have wrote another detailed how to for how to install SUSE Linux on Hyper-V. The article included how to install IC as well how to compile the required para-virtualization Kernel. I believe this will be quite useful to many people who are trying to install any Linux flavor on Hyper-V as it can add a bit more to the howtoforge article linked to below as well its showing it for a different flavor. You can find the article at:

    Install SUSE Linux Enterprise 10 SP1 & Component Integration for Linux on Hyper-V

    I hope this help people on this forum, I will be following comments on here often as well to update the article accordingly and would appreciate any feed backs.

  4. Timcco

    Timcco New Member

    I followed the tutorial. After the installation on Centos 5.4 32bit, which runs as a VM under Windows Server 2008, I can see "All services offered" in Virtual Machine Settings-Management-Integration Services, but click on VM shows Heartbeat: No contact. Shut Down and other is not possbile from Hyper-V manager.
    Why? What about "Rebuilding the Xen kernel and “install” it in place of the existing kernel" and "Install the hypercall adapter", that is in tutorial for Suse?

    # lsmod | grep vsc
    netvsc 45232 0
    storvsc 36772 0
    blkvsc 40260 3
    vmbus 56264 3 netvsc,storvsc,blkvsc
    scsi_mod 141717 5 scsi_dh,storvsc,blkvsc,libata,sd_mod

Share This Page