Centos as Gateway server.

Discussion in 'Server Operation' started by ruben23, Oct 13, 2008.

  1. ruben23

    ruben23 New Member

    Hi to all....i would like to ask help about my centos gateway server...i setup a gateway server on my network to be able to share internet with my private network.....in my gateway server i already can browse to the internet but with the dhcp function i think its not working....my client PC can ping the local ip of my gateway server..please help how to proceed with this...thanks:confused:
     
  2. ruben23

    ruben23 New Member

    i follow the how to of Home Gateway Firewall With DHCP Server For Connection Sharing..i already review it for several times...still my client PC cant connect with the internet..
     
  3. ruben23

    ruben23 New Member

    hi anyone help........:confused::(
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Is your client PC a Linux system? If so, please post the outputs of
    Code:
    ifconfig
    and
    Code:
    route -nee
    on that system.
     
  5. ruben23

    ruben23 New Member

    no...my client PC are Windows xp...my configuration is:

    PC-1
    IP add=192.168.2.5
    Subnet mask-255.255.255.0
    Gateway=192.168.2.1
    Dns=( given by my ISP)

    .....plus one to every IP to the next client PC.



    Server Gateway

    LOCAL ETHERNET
    eth1= local ip ( 192.168.2.1)
    submask= 255.255.255.0
    Gateway=192.168.2.1

    EXTERNAL ETHERNET
    eth2= ISP static IP (x.x.x.x)
    submask= 255.255.255.248
    Gateway= x.x.x.x

    thats my initial config...
     
  6. ruben23

    ruben23 New Member

    And my server Kernel Ip routing is:

    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface MSS Window irtt
    192.168.2.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1 0 0 0
    0.0.0.0 192.168.2.1 0.0.0.0 UG 0 0 0 eth1 0 0 0
    :cool:
     
  7. marpada

    marpada New Member

    Did you enable the port_forwarding in the Centos server?

    Code:
    $ cat /proc/sys/net/ipv4/ip_forward
    if is set to 0 (disabled) you have to enable it

    and edit to make the change permanent /etc/sysctl.conf

    net.ipv4.ip_forward=1
    ________
    Vapoizers
    ________
    Black ass
     
    Last edited: May 13, 2011

Share This Page