CentOS and apache directives

Discussion in 'General' started by Aquiles dos Santos Crespo, Mar 29, 2018.

  1. Hello there,

    I have the ISPConfig installed on a CentOS 7 distro, it was running all perfect until i noticed that the uoload was on a jomla website was not working even after adding in the webdomain options the following:
    <IfModule mod_fcgid.c>
    FcgidConnectTimeout 300
    FcgidMaxRequestLen 15728640
    FcgidMaxRequestsPerProcess 100
    FcgidProcessLifeTime 7200

    The only way i had was to alter the mod conf file at "/etc/httpd/conf.d/fcgid.conf" the folowing :
    MaxRequestLen 1073741824
    With this i could go around the 500 error code. But shouldn't the APACHE use the Apache directive configuration Written in the ISPConfig has default to this web domain? Or is the any kind of troubleshooting that I must do? :(

    The rest of the server is working like a charm :) , didn't noticed anything more.

    Thanks in Advance
    Aquiles dos Santos Crespo
  2. till

    till Super Moderator Staff Member ISPConfig Developer


    MaxRequestLen 1073741824

    in apache directives should have had the same effect than adding it to the fcgid conf file. When you look at the documentation of the fcgi module in the apache docs, then you see that there are two different config syntax types available and in your first attempt, you used the wrong syntax for your fcgid version. You can set the config syntax type in ispconfig under system > server config > web as well.
  3. Thanks For the Answer.
    So i should be using this instead ?
    <IfModule mod_fcgid.c>
    ConnectTimeout 300
    MaxRequestLen 1073741824
    MaxRequestsPerProcess 100
    ProcessLifeTime 7200
    i am going to test and post back later

    Many thanks with the best regards
    Aquiles dos Santos Crespo
  4. :( Nop I am Still having the same 500 error after the upload
    But i noticed that under the FastCGI tab in server config the FastCGI config syntax has to choose apache 2.0 and 2.2 but i am using the apache httpd-2.4.6-67.el7.centos.6.x86_64

    can that inerfere with this? :(

    i am realy a bit lost....
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes. that's what I meant by that the syntax can be switched. Try to use the other syntax there.
  6. I tried everything I could, and is still not successful. :(

    is there any other configuration that can be messing up this?

    I am really thinking in Changing the OS to Debian and start all again
    Last edited: Mar 29, 2018

Share This Page