CentOS 6 and Dovecot 2

Discussion in 'Installation/Configuration' started by m.naumann, Oct 2, 2012.

  1. m.naumann

    m.naumann New Member

    Hi,

    I'd like to try using ISPConfig (3) on CentOS 6 with Dovecot 2. As far as I know this is not yet supported (is this still correct?), so for now it would be nice to just have a test installation based on it, if that's possible. I do know that ISPConfig 3 works with Dovecot 2 on Debian 6, so I assume it is possible to make ISPConfig recognize and configure Dovecot 2 on CentOS 6, too.

    However, last time I tried it would not do it automatically, so I'm wondernig whether this is now a supported features or whether it's possible to force it, overriding defaults.

    Thanks in advance.
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. m.naumann

    m.naumann New Member

    That's great! I'm really looking forward to having Dovecot 2 working on this CentOS system with the latest ISPConfig 3.
     
  4. m.naumann

    m.naumann New Member

    Hmm, I'm not sure this would really work now, or maybe I'm doing something wrong - please help!

    On a CentOS 6.3 system I had previously setup ISPConfig on, I just removed all dovecot packages, ensured I had all CentOS repositories installed which are listed in

    http://www.howtoforge.com/perfect-server-centos-6.3-x86_64-apache2-dovecot-ispconfig-3

    (that's with the exception of the DAG repository, but this shouldn't matter),
    then installed the dovecot packages listed in the how-to. I end up with dovecot configuration in /etc/dovecot/ with the main dovecot configuration file located at /etc/dovecot/dovecot.conf.

    Then I ran install/update.php from the ISPConfig-3.0.4.6 tar.gz. This script now added /etc/dovecot.conf and /etc/dovecot-sql.conf, so two dovecot configuration files which use the Dovcecot 1.x configuration file layout, storing the configuration directly in /etc. Now I grep all the Dovecot configuration files for something ISPConfig related:

    Code:
    [root@ispconfig ~]# grep -ir ispconfig /etc/dovecot*
    /etc/dovecot-sql.conf:connect = host=localhost dbname=dbispconfig user=ispconfig password=[redacted]
    /etc/dovecot-sql.conf~:connect = host=localhost dbname=dbispconfig user=ispconfig password=[redacted]
    [root@ispconfig ~]#
    So apparently the ISPConfig 3.0.4.6 update script is assuming that I have dovecot 1.x installed (but I don't, I have 2.x). Should I try tp uninstall, then reinstall ISPConfig? Is there anything else I'm missing / doing wrong?

    It may be worth pointing out that I'm installing in an OpenVZ container and that the updater script prints this on screen:
    Code:
    Operating System: Redhat or compatible, unknown version.
    This system is:
    Code:
    [root@ispconfig ~]# cat /etc/redhat-release 
    CentOS release 6.3 (Final)
    [root@ispconfig ~]#
    Thanks in advance.
     
    Last edited: Oct 4, 2012
  5. m.naumann

    m.naumann New Member

    I would very much appreciate some feedback on this one...
     
  6. m.naumann

    m.naumann New Member

    Third and last attempt: bump
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Replace the files /etc/dovecot/dovecot.conf and /etc/dovecot/dovecot-sql.conf with symlinks to /etc/dovecot.conf and /etc/dovecot-sql.conf if the paths on your server do not match with the config file paths.
     

Share This Page