CentOS 6.4 x86_64 - ISPConfig 3.0.5.1 - Dovecot Errors

Discussion in 'Installation/Configuration' started by Hairy, Mar 22, 2013.

  1. Hairy

    Hairy New Member

    I just did a fresh installation of The Perfect Server - CentOS 6.4 x86_64 (Apache2, Dovecot, ISPConfig 3) and ISPConfig 3.0.5.1. There are some things that don't work correctly.

    On my old installation of CentOS 6.3 with ISPConfig 3.0.4.6, the dovecot.i686 1:2.0.9-2.el6_1.1 conf files are located at:
    /etc/dovecot-sql.conf
    /etc/dovecot.conf

    On the new installation of Centos 6.4 and ISPConfig 3.0.5.1, the dovecot.x86_64 1:2.0.9-5.el6 conf files are located at:
    /etc/dovecot/dovecot-sql.conf
    /etc/dovecot/dovecot.conf

    ISPConfig shows an error in the ISPConfig Mail - Log files panel as follows:
    Mar 21 22:34:07 pluto clamd[2049]: SelfCheck: Database status OK.
    Mar 21 22:35:02 pluto dovecot: imap-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured
    Mar 21 22:35:02 pluto postfix/smtpd[28444]: connect from localhost[::1]
    Mar 21 22:35:02 pluto dovecot: auth: Error: Can't open configuration file /etc/dovecot-sql.conf: No such file or directory
    Mar 21 22:35:02 pluto dovecot: master: Error: service(auth): command startup failed, throttling
    Mar 21 22:35:02 pluto dovecot: log: Error: service(auth): child 28452 returned error 89 (Fatal failure)
    Mar 21 22:35:02 pluto postfix/smtpd[28444]: fatal: no SASL authentication mechanisms
    Mar 21 22:35:03 pluto postfix/master[2134]: warning: process /usr/libexec/postfix/smtpd pid 28444 exit status 1
    Mar 21 22:35:03 pluto postfix/master[2134]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
    Mar 21 22:35:37 pluto dovecot: pop3-login: Error: Timeout waiting for handshake from auth server. my pid=28445, input bytes=0
    Mar 21 22:36:02 pluto dovecot: auth: Error: Can't open configuration file /etc/dovecot-sql.conf: No such file or directory
    Mar 21 22:36:02 pluto dovecot: log: Error: service(auth): child 28489 returned error 89 (Fatal failure)
    Mar 21 22:36:02 pluto dovecot: master: Error: service(auth): command startup failed, throttling
    Mar 21 22:36:32 pluto dovecot: pop3-login: Error: Timeout waiting for handshake from auth server. my pid=28445, input bytes=0
    Mar 21 22:37:02 pluto dovecot: pop3-login: Error: Timeout waiting for handshake from auth server. my pid=28445, input bytes=0
    Mar 21 22:37:02 pluto dovecot: auth: Error: Can't open configuration file /etc/dovecot-sql.conf: No such file or directory
    Mar 21 22:37:02 pluto dovecot: log: Error: service(auth): child 28509 returned error 89 (Fatal failure)
    Mar 21 22:37:02 pluto dovecot: master: Error: service(auth): command startup failed, throttling
    Mar 21 22:37:37 pluto dovecot: pop3-login: Error: Timeout waiting for handshake from auth server. my pid=28445, input bytes=0
    Mar 21 22:38:02 pluto dovecot: pop3-login: Disconnected: Inactivity (no auth attempts): rip=::1, lip=::1, secured
    Mar 21 22:38:02 pluto dovecot: auth: Error: Can't open configuration file /etc/dovecot-sql.conf: No such file or directory
    Mar 21 22:38:02 pluto dovecot: master: Error: service(auth): command startup failed, throttling
    Mar 21 22:38:02 pluto dovecot: log: Error: service(auth): child 28528 returned error 89 (Fatal failure)

    I patched up some of these errors by typing the following commands:
    ln -s /etc/dovecot/dovecot-sql.conf /etc/dovecot-sql.conf
    ln -s /etc/dovecot/dovecot.conf /etc/dovecot.conf

    Can the author please fix the installation guide and advise us of the proper way to fix the errors for The Perfect Server - CentOS 6.4 x86_64 (Apache2, Dovecot, ISPConfig 3)?
     
  2. hklcf

    hklcf New Member

    work, thanks :p
     
  3. Hairy

    Hairy New Member

    @hklcf You are welcome. Push the Thanks button if it worked for you.

    However, I still would like to have my 2 questions answered. As it currently stands, anyone who follows The Perfect Server - CentOS 6.4 x86_64 (Apache2, Dovecot, ISPConfig 3) and ISPConfig 3.0.5.1, will have a non-working server. I would like the whole world to enjoy ISPConfig. Thank you to the authors for putting so much time and effort into this project.

    1) Will the author fix The Perfect Server - CentOS 6.4 x86_64 (Apache2, Dovecot, ISPConfig 3) installation guide, so that everyone can enjoy this software?
    2) What is the correct way to make everything work correctly? My solution was meant to be temporary until the author can tell us the correct way to fix the problems that occur.
     
  4. doughahn56

    doughahn56 New Member

    Thanks

    that ended a 2 hour battle with google. I could not find the thanks button but

    thankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyouthankyou!!!!!!!!:):):):)
     
  5. Hairy

    Hairy New Member

    I am very happy that the end consumers are finding my solutions to all of the problems setting up this installation helpful. It's a shame that the authors of the software don't seem to care about all of the mistakes being made in the tutorials and the software itself. The authors have done a tremendous amount of awesome work on this project, but it all seems in vain when they refuse to acknowledge the smallest mistakes made in the tutorial that make the whole project useless for someone who isn't able to figure out the small mistakes that were made.

    If you followed the tutorial exactly as it's written, then don't forget to fix all of the other non-working services on your system as well. You've already fixed dovecot and postfix. Pure-ftpd will need reconfigured for TLS, mailman will need the 'en' language selected, and other services can be made to work more fully. A quick search for posts made by me should shed some light on fixing some of these things.

    Thanks for letting me know that you appreciate my post.
     
  6. SunnyD

    SunnyD New Member

    That's a bit arrogant of you to say something like that, especially since the issue was addressed in the user comments in the tutorial pages.
     
  7. Hairy

    Hairy New Member

    First, that's a bit arrogant for you to say, since you are unaware that I sent a letter to the author. As a matter of fact, you have no idea of all the places that I have posted asking for help.

    Second, go look up the word arrogant, because you obviously don't know what it means. How is it arrogant to say that some people (me included) need the authors to give us better instructions because we aren't able to figure out all the small mistakes that were made?

    Third, look up the word douchebag while you're at it. You'll see a picture of yourself.
     
  8. MostHostLA

    MostHostLA New Member

    Think I found the 'proper' fix

    http://www.howtoforge.com/perfect-s...-apache2-dovecot-ispconfig-3-p6#comment-33574

    Changing the configuration seems a better method, however the link works just as well.
     
  9. bszb1

    bszb1 New Member

    thank U! saved for me about 72 working hours...
     

Share This Page