CentOS 6.4 x86_64 - ISPConfig 3.0.5.1 - APS Installer Errors

Discussion in 'Installation/Configuration' started by Hairy, Mar 22, 2013.

Thread Status:
Not open for further replies.
  1. Hairy

    Hairy New Member

    I'm still searching for an answer as to why the APS Installer gives the error listed in this thread.

    I would like to offer a cash reward via paypal or money order to anyone who can answer why my APS Installer doesn't work.

    Please read this entire thread before sending me questions that have already been answered.

    If you think that you know why it doesn't work, please don't hesitate to send me a message. You will only become richer, if you are right.
     
  2. electronixcraft

    electronixcraft New Member

    THis is not working due to this bug FS#2431 - APS list update failed.

    Hi!
    I think there is a bug in aps_crawler.inc.php.
    In line 223:
    preg_match_all("/\<a href=\"(.+)\/\" class=\"vendor\"/i", $vendor_page, $matches);
    You take the href from the result page, which was http://appscatalog.com/all-app/. Something probably changed with listing, because that page returns the links as relative, so taking out the relative part of the url is not enough.

    I made a fast dirty hack on my side, just modify the formatVendorCallback to return '/all-app/'.$array_item.'.atom?vendor='.$array_item.'&pageSize=100'; and it is almost ok.

    But something still buggy, because the download of some packages simply fail with this error:
    "[INTERFACE]: APS crawler: String could not be parsed as XML"
    Maybe the package's atom feed is missing or something, but you can easily avoid that by check the returned page for xml validity, by adding this line

    if (!simplexml_load_string($xml)) continue;

    to the inner "for" loop where you fetch the packages. (Probably would be better to exception check with simpleXMLElement, but I didnt want to mess so much with that code, just want a working aps installer:) )

    Now, I can list and install packages without an issue:)
     
    Last edited by a moderator: Apr 28, 2013
  3. Hairy

    Hairy New Member

    Thank you for your reply. I will be trying this soon, but atm I am busy with work. If this solution works, I will be sending you a cash payment.

    Thank you for actually addressing the issue, instead of saying things like you loaded a VMWare image of a completely different tutorial, and got that particular tutorial to work after changing and updating the code, or asking if I have cURL installed, which was answered in the very first message of this thread.
     
  4. Hairy

    Hairy New Member

    I wish to retract my Thank You for the solution from electronixcraft. After looking at the bug tracker, I can clearly see that you did nothing more than paste, exactly as it was written, from a bug that is claimed to have been fixed back in October of 2012.

    I have clearly stated throughout this thread that I am using the current version of ISPConfig. My aps_crawler.inc.php doesn't even match the one being referred to in the bug. This is obvious in numerous places. Furthermore, the current ISPConfig doesn't even have a "for" loop which is supposed to be edited to fix this bug. I do however have a "foreach" loop. Still, the line numbers referred to in the bug don't even match the ones in the current version.

    This solution was a waste of time, since the bug being referred to was supposedly fixed last year, and because the block that is supposed to be edited doesn't even exist.

    Any more solutions are welcomed, as I am still trying to figure this out.
     
  5. electronixcraft

    electronixcraft New Member

    Sorry sir for the Copy Paste !!! But i found solution

    Hello sir, I am newbie :-( .I have been testing all free server control panels for last two months .Like you i was also facing the XML error in the latest Ispconfig release .But Now it Seems to be solved .

    I installed a fresh installation using the script

    https://github.com/KardiWeb/ISPConfig-Debian-Autoinstaller


    Now, It does not install the Php-Curl Installation ,Hence in shell prompt i ran

    apt-get install php5-mysql php5-curl php5-gd php5-intl php-pear php5-imagick php5-imap php5-mcrypt php5-memcache php5-ming php5-ps php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl

    And Now The package Updater Works fine :D ,No more XML Error .

    I had tried to raise a bug in bugtracker but it was declined by project manager
    saying there is no error in package updater.Yes there is no error in it .The error is with installation method .:rolleyes:
     
  6. till

    till Super Moderator

    The installation tool you used to install ispconfig is not compatible with ispconfig 3.0.5 if it does not install php5-curl, it is not developed nor supported by the ispconfig project. So you will understand that we wil not accpet bugreports caused by third party software, especially when several core devs confirmed that the bug does not exist when the system is installed as described in the official guides.

    If you want to get a correct and complete install of ispconfig, use one of the official installation guides from ispconfig.org
     
  7. Hairy

    Hairy New Member

    electronixcraft,

    In addition to what till said, I would also like to point out that the link you gave is for Debian and has nothing to do whatsoever with CentOS.
     
  8. DeCBiT

    DeCBiT New Member

    Hi,
    first of all, thanks a lot for ISPConfig a so great and useful software.

    I tryed a fresh install of ISPConfig 3.0.5.2 and 3.0.5.1 with tre different OS (centos 6.4, Debian 6 and Ubuntu 12.04) following, step by step the how-to, but nothing, always the same error updating package list:

    HTML:
    APS crawler: String could not be parsed as XML
    After many hours and tests I discovered that the problem wasn't the OS but the open_basedir directive written by the installation procedure:

    HTML:
    [website_path]/web:[website_path]/private:[website_path]/tmp:/var/www/[website_domain]/web:/srv/www/[website_domain]/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/usr/share/php

    With those settings, the APS php script cannot access to ISPCconfig directory and to solve the problem is sufficient go to System -> Server Config -> Web -> PHP setting, add the path /usr/local/ispconfig and save the settings.

    Now, the command "updating package list" should work without problem.
     
  9. Hairy

    Hairy New Member

    Thank you DeCBit for the suggestion.

    I have also tried Ubuntu, like you suggested, and I get the same exact error as on CentOS.

    I went to System->Server Config->server1.example.com->Web->PHP Settings->PHP open_basedir

    I added /usr/local/ispconfig and I get the same exact error.

    HTML:
    [website_path]/web:[website_path]/private:[website_path]/tmp:/var/www/[website_domain]/web:/srv/www/[website_domain]/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/usr/share/php:/usr/local/ispconfig
    HTML:
    APS crawler: String could not be parsed as XML
    Suggestions are still welcomed.
     
  10. monkfish

    monkfish New Member

    Hairy,

    Sorry to hear you're still having issues with this. Clearly the (non-ISPConfig related!) issue I had wasn't the same problem.

    I did not ever add in /usr/local/ispconfig to system PHP open_basedir. Mine currently looks like this on one machine (entry to /srv removed as that folder is completely empty on my install):-

    Code:
    [website_path]/web:[website_path]/private:[website_path]/tmp:/var/www/[website_domain]/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/usr/share/php
    
    On another machine with sites configured in different folder, config looks like this:-

    Code:
    [website_path]/web:[website_path]/private:[website_path]/tmp:/home/default/[website_domain]/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/usr/share/php
    

    Happy to compare configuration of your Centos 6.4 machine against three of my working ones, see if that assists you nail the issue?

    (edited to add my php open_basedir config)
     
    Last edited: May 11, 2013
  11. Hairy

    Hairy New Member

    Thank you for your help.

    I followed the guide, so my config line looks like your first config line using /var/www instead of /home.

    It looks like your config line is the same as mine except the /srv part. That must not be the problem, if you didn't have to edit your config line to make the APS Installer work.

    Still searching for the answer...
     
  12. monkfish

    monkfish New Member

    Hairy, still cannot reproduce the error you are seeing on any of my kit (CentOS 6.4 x64)

    For me, the APS installer was an added bonus into an already cracking interface and since it was added I have got around 40 different sites both internal and web-facing with packages downloaded and deployed using it.

    I reckon a way forward for you would be to download some of the virtual images that you can access with subscription.

    Check to see if that runs and gives same error - if it does then perhaps something environmental outside of your ispconfig server - eg. are you behind any restrictive firewall or proxy server.

    If it doesnt give the error then points to build issue on your server.

    I'd be checking/comparing anaconda.ks.cfg and install.log files to see what was installed at build time. Also /var/log/yum.log files to see what packages added on top, etc. A downloaded working version will at least give you a clue as to whats going on with yours.

    I've been through a few control panels and regard ISPConfig as the best one for my purposes. Therefore happy to help others if I at all can.
     
  13. Hairy

    Hairy New Member

    I also think that ISPConfig is best for my purposes. I love it. The APS Installer is just be an added bonus.

    I have gotten a break on this issue. I now have a working APS Installer on a server that I don't have physical access to. I didn't have any problems getting the APS Installer to work on this server that is outside of my network.

    I'm giving up on figuring out why it doesn't work in my network, since I have a working one now.

    I really appreciate everyone's help.
     
  14. Nilpo

    Nilpo HowtoForge Supporter

    I would lean heavily toward the idea that it's a firewall issue. Sorry you couldn't get this working. I'm glad you've narrowed the problem down to something local as the issue.
     
  15. Hairy

    Hairy New Member

    I couldn't sleep without looking at this more, even though I said I give up.

    I just spent 12 more hours on this. I replaced a router on my network with a brand new one, and did a fresh install, and everything works. I put the old router back on the network, wiped the drive and did a fresh install again, and the same error that was occurring is still there. I would say that the problem is certainly narrowed down to my router.

    Both routers are Belkin and both are setup exactly the same.

    ........ Maybe the firmware in the router??? I don't know.

    I am truly done with this issue for now. lol

    Thanks everyone!
     
  16. Hairy

    Hairy New Member

    The router that was causing the APS Installer errors is now dead. Over the last couple of weeks, the router was blocking internet on some computers, and blocking lan traffic from other computers. This router literally went hay-wire. Now, it has completely stopped working.

    My neighbor and I placed this router at the end of his firing range, and it was the most fun I have ever had with a router. This router is now literally pushing up daisies.

    I have not been able to replicate the APS Installer problem with ANY other router. I have tried 5 now.

    I have been following ISPConfig for 10 years now, and I must say that the APS Installer is by far, my most favorite function that has ever been added.

    Thanks again everyone!
     
  17. Igor Mišić

    Igor Mišić New Member

    Hi guys I just install ISPConfig on ubuntu Server 14.04 and I also can't get APS packages.

    I have found this error in apache error log every time when I try to Update packagelist:
    mod_fcgid: stderr: PHP Warning:


    Code:
    [Wed Mar 25 03:41:28.008457 2015] [fcgid:warn] [pid 10259] [client 93.137.234.43:49380] mod_fcgid: stderr: PHP Warning:  SimpleXMLElement::__construct(): Entity: line 1: parser error : StartTag: invalid element name in /usr/local/ispconfig/interface/lib/classes/aps_crawler.inc.php on line 288, referer: https://sniva.com:8080/index.php
    [Wed Mar 25 03:41:28.008660 2015] [fcgid:warn] [pid 10259] [client 93.137.234.43:49380] mod_fcgid: stderr: PHP Warning:  SimpleXMLElement::__construct(): &lt; in /usr/local/ispconfig/interface/lib/classes/aps_crawler.inc.php on line 288, referer: https://sniva.com:8080/index.php
    [Wed Mar 25 03:41:28.008673 2015] [fcgid:warn] [pid 10259] [client 93.137.234.43:49380] mod_fcgid: stderr: PHP Warning:  SimpleXMLElement::__construct():  ^ in /usr/local/ispconfig/interface/lib/classes/aps_crawler.inc.php on line 288, referer: https://sniva.com:8080/index.php
    Is that maybe connected?


    I have installed php5-curl.
     
    Last edited: Mar 25, 2015
  18. till

    till Super Moderator

    Igor Mišić likes this.
Thread Status:
Not open for further replies.

Share This Page