CentOS 6.4 x86_64 - ISPConfig 3.0.5.1 - APS Installer Errors

Discussion in 'Installation/Configuration' started by Hairy, Mar 22, 2013.

  1. Hairy

    Hairy New Member

    I just did a fresh installation of The Perfect Server - CentOS 6.4 x86_64 (Apache2, Dovecot, ISPConfig 3) and ISPConfig 3.0.5.1. There are some things that don't work correctly.

    I browse to ISPConfig control panel -> Sites -> APS Installer -> Update Packagelist. Then, I click the button that says 'Update Packagelist'. Then, I see a box with pinwheel going around for awhile. Once the pinwheel stops, it shows the error:

    Error
    No packages to read in

    Then, I browse to ISPConfig CP - > Monitor -> Show System-Log. The log shows the following error:

    2013-03-22 08:54 Error [INTERFACE]: APS crawler: No packages to read in
    2013-03-22 08:54 Error [INTERFACE]: APS crawler: String could not be parsed as XML

    Can someone please advise me how to fix this and make it work properly?
     
  2. almere

    almere HowtoForge Supporter

    Do you have cURL library installed?
     
  3. Hairy

    Hairy New Member

    If it is part of The Perfect Server - CentOS 6.4 x86_64 (Apache2, Dovecot, ISPConfig 3) and ISPConfig 3.0.5.1 installation guide, then I have it installed.

    Here is my output:
    [root@pluto ~]# curl -V
    curl 7.19.7 (x86_64-redhat-linux-gnu) libcurl/7.19.7 NSS/3.13.6.0 zlib/1.2.3 libidn/1.18 libssh2/1.4.2
    Protocols: tftp ftp telnet dict ldap ldaps http file https ftps scp sftp
    Features: GSS-Negotiate IDN IPv6 Largefile NTLM SSL libz
     
  4. Hairy

    Hairy New Member

    CentOS 6.4 x86_64 APS Installer Doesn't Work - Help?

    Does anyone have any ideas why the APS Installer doesn't work correctly with The Perfect Server - CentOS 6.4 x86_64 (Apache2, Dovecot, ISPConfig 3) and ISPConfig 3.0.5.1?

    Can anyone tell me where some physical logs might be that can help determine the problem?
     
  5. SunnyD

    SunnyD New Member

    I can tell you that the APS installer DOES work correctly with that setup tutorial, as I followed it for an install and APS is working fine.

    I can't answer your question about the logs, but I can suggest that you attempt to "update" your install of ISPConfig to see if that might fix APS. In my learning process for ISPConfig on an initial install, I had a similar issue where APS would fail to retrieve the package list and never update. I went and ran update.php from the ISPConfig install directory, and once it was done APS was working fine.
     
  6. Hairy

    Hairy New Member

    Thank you for the reply. I've tried updating ISPConfig using the update.php file and the APS Installer still does not work.

    Your statements are contradictory. You first state:
    Then, you state that when you followed the guide, it DIDN'T work and you had to run an update script:
    Can you think of anything else that you may have done that fixed the problem when you were having your learning experience?

    I can confirm for a fact that you will not have a working server, if you follow the guide. Unless you consider it a working server, even though you have no dovecot, pop3, or imap.

    See:
    http://www.howtoforge.com/forums/showthread.php?t=61074

    Here are some more small things that are wrong with the guide:
    http://www.howtoforge.com/forums/showthread.php?t=61088
    http://www.howtoforge.com/forums/showthread.php?t=61091

    I am considering doing 2 fresh installs tonight on 2 unused computers and see what happens. I will post the results, if I do.
     
  7. SunnyD

    SunnyD New Member

    Sorry if you misunderstood, there was nothing contradictory. My initial attempts playing around with ISPConfig yielded the APS installer not retrieving the package list. I ran update, after which APS was able to update and pull the package list properly. My "guess" is during the initial setup I had an issue where name resolution on the server stopped working properly for a time, which may have corrupted something along the way.

    I then wiped the server with a fresh OS install and followed that guide from the start, APS works fine from the initial install.

    As I said - the particular guide you reference works fine with regards to APS. The issues with dovecot are covered in the user comments on the respective pages.

    I apologize if this didn't help. Hopefully you can find an answer.
     
  8. Hairy

    Hairy New Member

    Thanks for the help.

    OK. I've just finished two more fresh installs. I followed the guide exactly as written on the first computer. On the second computer I substituted the 32 bit architecture. I can confirm now with 3 installs that the APS Installer will NOT work, by following the guide located here:

    http://www.howtoforge.com/perfect-server-centos-6.4-x86_64-apache2-dovecot-ispconfig-3

    I've also viewed the online demo of ISPConfig, and I noticed that the APS Installer doesn't work properly on there either. The online demo gives the exact same errors that I am having.

    Error
    No packages to read in

    and

    2013-03-27 00:30 Error [INTERFACE]: APS crawler: No packages to read in
    2013-03-27 00:30 Error [INTERFACE]: APS crawler: String could not be parsed as XML

    Any help is appreciated. Thanks.
     
  9. Nilpo

    Nilpo HowtoForge Supporter

    I am also having this problem. Can anyone offer a solution?
     
  10. Hairy

    Hairy New Member

    ISPConfig 3.0.5.2 was released today. I updated my ISPConfig on all three test machines. I tried clicking the APS Installer Update Packagelist button and I still get the same errors on all three CentOS 6.4 servers.

    Error
    No packages to read in

    and

    2013-03-28 16:02 Error [INTERFACE]: APS crawler: No packages to read in
    2013-03-28 16:02 Error [INTERFACE]: APS crawler: String could not be parsed as XML
     
  11. monkfish

    monkfish New Member

    check your dns and any firewalling?

    Cannot offer an exact fix, just what I came across...

    I just upgraded a few versions on CentOS hardware that did not have the APS functionality in and on one machine got a similar error to you.

    I did 3 fresh installs and it all works first time out of the box. Other glitches I came across have nothing to do with APS installer.

    On my Centos 6.4 x86_64 architecture it turns out that the machine that was failing did not have proper dns resolution. This was traced to an update of the bind package that inserts a line into /etc/named.conf looking for a non-existent file (/etc/named.conf.local). So named refused to start. On clicking "update package list" the machine had no dns and therefore couldnt grab the list.

    Once resolved ("touch /etc/named.conf.local" and "service named restart") it worked. This is a distro problem and NOT an ispconfig problem.
    Not saying thats your issue, just describing what happened my end.
     
  12. Hairy

    Hairy New Member

    Thank you for confirming that you had 3 successful installs where the APS Installer works fine. It appears that I am the only one having this issue. Not on 1, but all 3 installations. I still don't know why my APS Installer doesn't work.

    I checked my /etc/named.conf.local file and restarted named. DNS appears to be working fine.

    Everything else appears to be working fine. Any more help is appreciated. Thanks for the help everyone.
     
  13. Nilpo

    Nilpo HowtoForge Supporter

    Are all of your servers using identical configurations? I'm referring to distribution and packages.
     
  14. Hairy

    Hairy New Member

    Sorry for the delay in responding. I am still trying to figure this out. Sorry for not being clear about the configurations. To make it very clear, here it is again.

    I have 3 separate computers that are all independent single dedicated servers. I installed CentOS 6.4 on each one of them, following the guide located here www.howtoforge.com/perfect-server-centos-6.4-x86_64-apache2-dovecot-ispconfig-3, exactly as it is written. All three computers have the EXACT same configuration obviously, since I followed the EXACT same instructions for each.

    Everything seems to work fine on all of them, except the APS Installer. I realized that there was a chance, small but still a chance, that I didn't follow the guide correctly. So, I decided to wipe all three computers clean. Then, I meticulously followed the instructions again setting each of the three computers up again from scratch. Then, I doubled checked my history and compared every single line in history to the lines in the guide to make sure that every line is exactly as it is written in the tutorial.

    After I was all done, I tried the update packagelist button for the APS Installer and it still gives me the same error on all 3 servers.


    Error
    No packages to read in

    Then, I go to the Monitor tab in ISPConfig and show the system log and it shows this error:

    2013-04-04 01:33 Error [INTERFACE]: APS crawler: No packages to read in
    2013-04-04 01:33 Error [INTERFACE]: APS crawler: String could not be parsed as XML

    That's 6 setups, and all 6 have the exact same problem.
    I then went to the online demo of ISPConfig at http://demo3.ispconfig.org/ for fun just to look and see how the APS Installer works in action. The demo version gives the similar error that I am having.

    Error
    String could not be parsed as XML

    Any help is appreciated. Thanks everyone!
     
  15. till

    till Super Moderator

    The demo is not a ispconfig installation, so downloading any packages can not work of course as we disabled that. The demo is a modified version of the interface pages to give a impression how ispconfig lookslike when it is installed. It does not have a server part nor does it contain all scripts

    I installed the latest ispconfig version on centos 6.3 and the aps installer works flawlessly. I used the vmware download of the perfect setup for this test, so it is a exact copy of the perfect setup guide without any modifications except of updating ispconfig to 3.0.5.2 first.
     
  16. Hairy

    Hairy New Member

    Thank you till.

    The reason that i referred to the online demo is because the error was similar to mine.

    Do you have any suggestions for troubleshooting this issue? I thank you for any suggestions.

    I've tried enabling debug mode in the control panel and clicking the update packagelist button again, but there is nothing different in the log.

    I have however noticed another error that occurs occasionally instead of the other error. I've clicked the button a hundred times now. Every once in a while i see this error:

    2013-04-03 14:34 Error [INTERFACE]: APS crawler: No packages to read in
    2013-04-03 14:34 Error [INTERFACE]: APS crawler: Unable to fetch vendors. Aborting

    Thanks again
     
  17. till

    till Super Moderator

    Do you use firewall which may block connections to apsstandard.org and is the php-curl module installed?
     
  18. Hairy

    Hairy New Member

    Installed Packages
    curl.x86_64 7.19.7-35.el6 @anaconda-CentOS-201303020151.x86_64/6.4
    libcurl.x86_64 7.19.7-35.el6 @anaconda-CentOS-201303020151.x86_64/6.4
    libcurl-devel.x86_64 7.19.7-35.el6 @base

    From phpinfo():
    cURL support enabled
    cURL Information 7.19.7
    Age 3
    Features
    AsynchDNS No
    Debug No
    GSS-Negotiate Yes
    IDN Yes
    IPv6 Yes
    Largefile Yes
    NTLM Yes
    SPNEGO No
    SSL Yes
    SSPI No
    krb4 No
    libz Yes
    CharConv No
    Protocols tftp, ftp, telnet, dict, ldap, ldaps, http, file, https, ftps, scp, sftp
    Host x86_64-redhat-linux-gnu
    SSL Version NSS/3.13.6.0
    ZLib Version 1.2.3
    libSSH Version libssh2/1.4.2

    From the command line works fine:
    [root@pluto ~]# curl http://apsstandard.org

    This does not work:
    [root@pluto ~]# curl https://apsstandard.org
    curl: (35) SSL connect error

    Still, looking forward to any suggestions. Thanks.
     
  19. Hairy

    Hairy New Member

    I thought that I should give this idea a go.

    First, I am wondering why you picked CentOS6.3 instead of the CentOS6.4 as described in this thread.

    Second, I am wondering if you wouldn't mind updating the instructions for importing VMware images into the free player. As it currently stands the instructions found here http://www.howtoforge.com/import_vmware_images are worthless. The links don't work that are supposed to point to the proper downloads. Then, when you find the proper download, you can't follow the instructions, because the the player doesn't look anythng like the player described in the instructions. Then, when you install the player, it asks you questions that are not covered in the instructions.

    Third, the instructions say to open the .vmx file into your player. I noticed that some of your VMware images available for download, don't have a .vmx file in the zipped download. For example, the CentOS 6.4 Perfect Server Setup that I am having problems with, is one of the downloads that doesn't have a .vmx file in it. Exactly how do you load one of these images into the VMware player please?

    Fourth, once you do find a download that does have a .vmx file in it, how do you log in as the root user? The tutorial doesn't give the root password, nor does it give a pasword on the images downloads page.

    Thanks.
     
  20. Hairy

    Hairy New Member

    I found the password on this page http://www.howtoforge.com/import_vmware_images. That answers that question. I still need help with the other questions.
     

Share This Page