Centos 6.4: Fresh Install Shows Apaches Test Site

Discussion in 'Installation/Configuration' started by Alisnasyon, Mar 30, 2013.

  1. Alisnasyon

    Alisnasyon New Member

    I am a beginner of ISPConfig, worked a Little bit with Linux :)

    I have Installed my Centos 6.4 and ISPConfig 3 with the http://www.howtoforge.com/perfect-server-centos-6.4-x86_64-apache2-dovecot-ispconfig-3
    tutorial.

    All nearly perfectly. After the install i can access phpymyadmin, MySQL work but i cannot reach the ISPConfig login page under http://IP:8080 or https://IP:8080 and the same with hostnames :(

    There is only the Apache2 Test Page visible and I cannot access to the ISPConfig login page.

    /etc/httpd/conf/sites-available/ispconfig.vhost:
    Code:
     Listen 8080
    NameVirtualHost *:8080
    
    <VirtualHost _default_:8080>
      ServerAdmin webmaster@localhost
    
      <FilesMatch "\.ph(p3?|tml)$">
        SetHandler None
      </FilesMatch>
    
      <IfModule mod_fcgid.c>
        DocumentRoot /var/www/ispconfig/
        SuexecUserGroup ispconfig ispconfig
        <Directory /var/www/ispconfig/>
          Options Indexes FollowSymLinks MultiViews +ExecCGI
          AllowOverride AuthConfig Indexes Limit Options FileInfo
          AddHandler fcgid-script .php
          FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
          Order allow,deny
          Allow from all
        </Directory>
        IPCCommTimeout  7200
            MaxRequestLen 15728640
      </IfModule>
    
      <IfModule mpm_itk_module>
        DocumentRoot /usr/local/ispconfig/interface/web/
            AssignUserId ispconfig ispconfig
        AddType application/x-httpd-php .php
        <Directory /usr/local/ispconfig/interface/web>
          # php_admin_value open_basedir "/usr/local/ispconfig/interface:/usr/share:/tmp"
          Options FollowSymLinks
          AllowOverride None
          Order allow,deny
          Allow from all
              php_value magic_quotes_gpc        0
        </Directory>
      </IfModule>
    
      # ErrorLog /var/log/apache2/error.log
      # CustomLog /var/log/apache2/access.log combined
      ServerSignature Off
    
      <IfModule mod_security2.c>
        SecRuleEngine Off
      </IfModule>
    
      # SSL Configuration
      SSLEngine On
      SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
      SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key
      #SSLCACertificateFile /usr/local/ispconfig/interface/ssl/ispserver.bundle
    
    </VirtualHost>
    
    <Directory /var/www/php-cgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <Directory /var/www/php-fcgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    I have tried to reinstall and/ or update ISPConfig but haven't got luck :(
     
    Last edited: Mar 30, 2013
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please post the output of:

    netstat -tap

    and

    iptables-L
     
  3. naresh.khokhani

    naresh.khokhani New Member

    I have the same problem as well, can you please help?

    Here is output of:

    [root@gateway data]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:pop3 *:* LISTEN 4324/dovecot
    tcp 0 0 localhost:dyna-access *:* LISTEN 1584/clamd
    tcp 0 0 *:imap *:* LISTEN 4324/dovecot
    tcp 0 0 *:sunrpc *:* LISTEN 1290/rpcbind
    tcp 0 0 gateway.artoon.com:domain *:* LISTEN 4463/named
    tcp 0 0 localhost:domain *:* LISTEN 4463/named
    tcp 0 0 *:ftp *:* LISTEN 4422/pure-ftpd (SER
    tcp 0 0 *:ssh *:* LISTEN 1576/sshd
    tcp 0 0 localhost:ipp *:* LISTEN 1449/cupsd
    tcp 0 0 localhost:rndc *:* LISTEN 4463/named
    tcp 0 0 *:smtp *:* LISTEN 4280/master
    tcp 0 0 *:imaps *:* LISTEN 4324/dovecot
    tcp 0 0 *:pop3s *:* LISTEN 4324/dovecot
    tcp 0 0 localhost:10024 *:* LISTEN 4313/amavisd (maste
    tcp 0 0 localhost:10025 *:* LISTEN 4280/master
    tcp 0 0 *:mysql *:* LISTEN 4180/mysqld
    tcp 0 0 *:56298 *:* LISTEN 1308/rpc.statd
    tcp 0 0 localhost:10025 localhost:49312 TIME_WAIT -
    tcp 0 0 gateway.artoon.com:ssh 192.168.0.130:52311 ESTABLISHED 1900/sshd
    tcp 0 0 localhost:46054 localhost:mysql TIME_WAIT -
    tcp 0 0 localhost:46058 localhost:mysql TIME_WAIT -
    tcp 0 0 localhost:mysql localhost:46060 ESTABLISHED 4180/mysqld
    tcp 0 0 localhost:46053 localhost:mysql TIME_WAIT -
    tcp 0 0 localhost:46060 localhost:mysql ESTABLISHED 4932/smtp
    tcp 0 0 *:pop3 *:* LISTEN 4324/dovecot
    tcp 0 0 *:imap *:* LISTEN 4324/dovecot
    tcp 0 0 *:sunrpc *:* LISTEN 1290/rpcbind
    tcp 0 0 *:webcache *:* LISTEN 4770/httpd
    tcp 0 0 *:http *:* LISTEN 4770/httpd
    tcp 0 0 *:tproxy *:* LISTEN 4770/httpd
    tcp 0 0 *:domain *:* LISTEN 4463/named
    tcp 0 0 *:ftp *:* LISTEN 4422/pure-ftpd (SER
    tcp 0 0 *:ssh *:* LISTEN 1576/sshd
    tcp 0 0 localhost:ipp *:* LISTEN 1449/cupsd
    tcp 0 0 localhost:rndc *:* LISTEN 4463/named
    tcp 0 0 *:smtp *:* LISTEN 4280/master
    tcp 0 0 *:https *:* LISTEN 4770/httpd
    tcp 0 0 *:39037 *:* LISTEN 1308/rpc.statd
    tcp 0 0 *:imaps *:* LISTEN 4324/dovecot
    tcp 0 0 *:pop3s *:* LISTEN 4324/dovecot
    tcp 1 0 localhost:pop3 localhost:39943 CLOSE_WAIT 4880/dovecot/pop3-l



    and here is output of:

    [root@gateway data]# iptables -L
    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    fail2ban-SSH tcp -- anywhere anywhere tcp dpt:ssh

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    Chain fail2ban-SSH (1 references)
    target prot opt source destination
    RETURN all -- anywhere anywhere


    The apache error log says:
    Directory index forbidden by Options directive: /var/www/html/


    And it displays me warnings when I restart apache:
    NameVirtualHost *:80 has no VirtualHosts
    NameVirtualHost *:443 has no VirtualHosts
    NameVirtualHost *:80 has no VirtualHosts
     
    Last edited: Apr 20, 2013
  4. naresh.khokhani

    naresh.khokhani New Member

    Is anyone going to reply on above issue? Please help!

    Thanks in advance :)

    Thank you,
    Naresh
     
  5. nark3d

    nark3d New Member

    Same issue here

    I'm having exactly the same problem, does anyone have a solution?
     
  6. nark3d

    nark3d New Member

    This fixed it for me

    After checking out the /etc/httpd/conf/sites-available/ispconfig.vhost file, it shows that it uses two modules: mod_fcgid.c and mpm_itk_module, neither of were installed in the tutorial.

    So, do the following:
    Code:
    yum install mod_fcgid httpd-itk
    /etc/init.d/httpd restart
    I had to reinstall ispconfig to get it to work after that, but you may get lucky.

    Cheers
    nark3d
     
  7. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The mpm_itk module is optional and not required. The mod_fcgi module is required and installed in the tutorial in chapter 15. See command:

    Code:
    yum install php php-devel php-gd php-imap php-ldap php-mysql php-odbc php-pear php-xml php-xmlrpc php-pecl-apc php-mbstring php-mcrypt php-mssql php-snmp php-soap php-tidy curl curl-devel perl-libwww-perl ImageMagick libxml2 libxml2-devel mod_fcgid php-cli httpd-devel
    I recommend to copy the commands to the server shell so you dont miss to install any modules, when you use a windows desktop to install the server, then you can use putty for that.
     
  8. tuvia

    tuvia New Member

    If you copy the exact line you mentioned, mod_fcgid does not get properly installed on Centos 6.4. Running yum install mod_fcgid httpd-itk afterwards will fix it. I do not know why this is or under what circumstances it is true, but it is certainly a reproducible issue.
     
  9. Hairy

    Hairy New Member

    I just tested this, since I like learning about CentOS. I've done about 30 ISPConfig installs in the past 2 months, and copying that line from the tutorial has always installed mod_fcgid properly for me.

    This output is just saying that haven't added any virtual hosts yet in ISPConfig.
     

Share This Page